Opened 11 years ago

Closed 5 months ago

#2787 closed bug (invalid)

clicks in audio with cpu activity (Echo Mia MIDI)

Reported by: nutela Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/Echo3g Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by stippi)

Play a wave file or mp3. Move any window or close or launch apps. Pops and clicks are heard in the audio playing, especially with high cpu usage.

Not sure if it is related to hrev27382. Enabling real time audio does improve the situation slightly.

expected behavior: silky smooth audio playback under all circumstances :)

Change History (11)

comment:1 Changed 11 years ago by stippi

Description: modified (diff)

comment:2 Changed 11 years ago by stippi

Well... do you use the OpenSound optional package? At which revision did you first notice the clicks?

comment:3 Changed 11 years ago by nutela

I'm not sure if it uses OpenSound optional package, I haven't specified so in the haiku.image? build file. Just added there 'echo24' Media prefs notes semi-correctly Echo Mia.

I'm sorry but I think these really audible clicks began from revs from a few weeks ago but I remember it not being 100% OK on Haiku ever...

On R5 playback is good beside the aliasing probably due to mixing but I build it a long time ago. IIRC there is only a echo.settings file on R5 not for Haiku where things like buffer size and sample rates can be set.

I could build the latest version for R5 but does it make sense? If I knew how to tweak the buffer size on Haiku maybe I could tell you more because now latency seems good (scrolling an jumping through audio in mediaplayer) but whenever something happens in the system even when it is practically idle there are clicks which are more severe (horrible) under load (esp firefox)

comment:4 in reply to:  3 Changed 11 years ago by korli

Replying to nutela: long time ago. IIRC there is only a echo.settings file on R5 not for Haiku where things like buffer size and sample rates can be set.

The same echo.settings file can be used on Haiku. It's just not included in the hd image.

comment:5 Changed 11 years ago by nutela

Copied the echo.settings from R5 to Haiku, uncommented the lines concerning sample rates, buffers, etc. but left everything default except sample rate which I set to 44100.

Restarted Media Preferences, problem still persists, and there are another bug; the settings are not read (system must be restarted, will file another bug for this)

After system restart problem still persist but settings are at least taken from echo.settings. So a buffer of 512 samples does not fix the problem. On R5 I can go as low as 64 samples on the same HW.

I recall something similar on R5 when I had BIOS USB emulation (so no driver for USB from R5, USB emulated through the BIOS), playing any audio and using USB mouse and keyboard resulted in severe 'clicks' in the audio output.

comment:6 Changed 11 years ago by nutela

This happens also when recording audio in SoundRecorder, movement of windows for example greatly adds clicks to the recording :(

comment:7 Changed 10 years ago by korli

Could you try to disable serial output in Haiku ? see in data/settings/kernel/drivers/kernel or config/settings/kernel/drivers/kernel

serial_debug_output false

comment:8 Changed 10 years ago by nutela

With my older card Cmedia 87xx (cmpci driver on bebits) disableing serial debug output doesn't help much.

Echo Mia Midi I have currently barrowed

comment:9 Changed 8 years ago by scottmc

Can you recheck this on a recent Haiku build and report back here? Perhaps try the alpha3 when it is available, which looks to be on or after June 20th, 2011.

comment:10 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/Echo3g

comment:11 Changed 5 months ago by waddlesplash

Resolution: invalid
Status: newclosed

No reply in 8 years.

Note: See TracTickets for help on using tickets.