Opened 11 years ago

Closed 8 months ago

#2812 closed bug (not reproducible)

System appears sleepy with disk activity

Reported by: jackburton Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

While doing a svn checkout of the haiku repository on my system (an intel core 2 DUO, with a core disabled due to ticket #2803), the system appears cyclically aslept: if I try to open a tracker window, it takes a couple of seconds to open, but this seems to happen cyclically, as I said. The cpu activity is low with some very occasional spikes, so it doesn't seem related to the above ticket. Top doesn't help much, althought it shows more or less the following pattern: svn spends a lot of time in kernel (while downloading the files), then it stops downloading for a while, and the thread "scsi scheduler" is the one which consumes most cpu (but never above 10% in that case), I guess while updating the svn database, and during that time, it seems like it blocks any other operation from/to disk.

Change History (9)

comment:1 Changed 11 years ago by jackburton

Summary: System appears sleepy with network activitySystem appears sleepy with disk activity

Looks like it's also reproducible by just copying a directory with many files (the haiku local repository, for example). Also with both cores enabled.

comment:2 Changed 11 years ago by jackburton

Resolution: fixed
Status: newclosed

This seems to have been fixed after Ingo's latest changes to the vm system.

comment:3 Changed 10 years ago by Adek336

Resolution: fixed
Status: closedreopened

Disk activity makes Haiku unresponsive; after you click on a, for example, menu, you have to wait many seconds before the menu shows up.

Note http://www.freelists.org/post/haiku-development/IO-scheduler-regression

Responsiveness is pretty important for the user experience.

comment:4 Changed 10 years ago by Adek336

*open big image with ShowImage - makes Haiku unresponsive; *select a fragment of the image, drag it a little bit, select another fragment, something like this often make Haiku unresponsive as well

I'm not sure if this is caused by the same bug.

comment:5 Changed 10 years ago by Adek336

Also slow is:

  • browsing the directory structure of the file system in the directory chooser of Expander while checking out sources with subversion.

comment:6 Changed 10 years ago by Adek336

Also note #2604.

comment:7 Changed 2 years ago by diver

This one is probably fixed now?

comment:8 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: reopenedassigned

comment:9 Changed 8 months ago by jackburton

Resolution: not reproducible
Status: assignedclosed

Probably fixed in the meantime: I don't have that machine anymore, but can't see this problem on any machine I tried.

Note: See TracTickets for help on using tickets.