Opened 11 years ago

Closed 11 years ago

#2888 closed bug (duplicate)

Tracker crash

Reported by: Adek336 Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When doing shutdown, Tracker crashes and a dialog box invites me to debug it.

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 99 called debugger(): Looper must be locked.
Reading symbols from /boot/beos/system/runtime_loader...done.
Loaded symbols for /boot/beos/system/runtime_loader
Reading symbols from /boot/beos/system/lib/libbe.so...done.
Loaded symbols for /boot/beos/system/lib/libbe.so
Reading symbols from /boot/beos/system/lib/libtracker.so...done.
Loaded symbols for /boot/beos/system/lib/libtracker.so
Reading symbols from /boot/beos/system/lib/libroot.so...done.
Loaded symbols for /boot/beos/system/lib/libroot.so
Reading symbols from /boot/beos/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/beos/system/lib/libstdc++.r4.so
Reading symbols from /boot/beos/system/lib/libtranslation.so...done.
Loaded symbols for /boot/beos/system/lib/libtranslation.so
Reading symbols from /boot/beos/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/beos/system/lib/libtextencoding.so
Reading symbols from /boot/beos/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/beos/system/lib/libilmimf.so...done.
Loaded symbols for /boot/beos/system/lib/libilmimf.so
Reading symbols from /boot/beos/system/lib/libz.so...done.
Loaded symbols for /boot/beos/system/lib/libz.so
Reading symbols from /boot/beos/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/beos/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/beos/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/beos/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/beos/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/WonderBrushTranslator
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/beos/system/Tracker (99) thread Tracker (99)]
0xffff0102 in ?? ()
(gdb) bt
#0  0xffff0102 in ?? ()
#1  0x006544b6 in debugger () from /boot/beos/system/lib/libroot.so
#2  0x002b2d95 in BLooper::check_lock () from /boot/beos/system/lib/libbe.so
#3  0x00354f50 in BView::_CheckLock () from /boot/beos/system/lib/libbe.so
#4  0x0034b2e0 in BView::Bounds () from /boot/beos/system/lib/libbe.so
#5  0x0034bd23 in BView::LeftTop () from /boot/beos/system/lib/libbe.so
#6  0x0056f682 in BPrivate::BPoseView::SaveState ()
   from /boot/beos/system/lib/libtracker.so
#7  0x004eaf1c in BPrivate::BContainerWindow::SaveState ()
   from /boot/beos/system/lib/libtracker.so
#8  0x005afbe3 in BPrivate::TTracker::QuitRequested ()
   from /boot/beos/system/lib/libtracker.so
#9  0x002b29a4 in BLooper::_QuitRequested ()
   from /boot/beos/system/lib/libbe.so
#10 0x002b0f76 in BLooper::DispatchMessage ()
   from /boot/beos/system/lib/libbe.so
#11 0x002a8151 in BApplication::DispatchMessage ()
   from /boot/beos/system/lib/libbe.so
#12 0x002b28f9 in BLooper::task_looper () from /boot/beos/system/lib/libbe.so
#13 0x002a68c1 in BApplication::Run () from /boot/beos/system/lib/libbe.so
#14 0x002009eb in main ()
(gdb) 

This has happened a lot of times to me. I suspect that whether it crashes or not, depends on what directories are open during shutdown.

Change History (8)

comment:1 by Adek336, 11 years ago

Sometimes it even doesn't show the Debug window after choosing "Debug" and the Shutdown dialog box hangs indefinitly on "Asking net_server to quit" or "Asking input_server to quit" or something alike, but the Desktop and the Tracker windows are still open and working.

I'm now able to reproduce the problem - a Tracker window has to be open on a directory on an ext3 partition.

comment:2 by aldeck, 11 years ago

Sounds similar to #2571

comment:3 by Adek336, 11 years ago

The ext3 partitions are mounted read-only. It also crashes when a directory from a BeFS partition mounted read-only has an open Tracker window; it doesn't crash if the BeFS partition is mounted read-write.

It also crashes on a FAT32 partition, regardless if it is mounted read-only or read-write.

comment:4 by aldeck, 11 years ago

Owner: changed from axeld to aldeck
Status: newassigned

I'll have look today.

comment:5 by aldeck, 11 years ago

Which revision did you try? Was 100% reproducible a few weeks ago but i can't reproduce anymore (hrev28204 on real hardware and hrev28244 on vmware).

comment:6 by aldeck, 11 years ago

It seems it was "fixed" between hrev28197 and hrev28204. Probably hrev28198. But it's more likely that the bug has always been there but recent changes (weeks ago) to the vm made it appear (and then disappear). I'll investigate a bit more before closing.

comment:7 by aldeck, 11 years ago

Hmm, forget about my last comment, my local copy of hrev28204 probably contained another fix commited later in hrev28205. Which by coincidence removed the faulty lines, accessing LeftTop().

I had troubles understanding the back trace since there was no call to LeftTop() anymore :)

I'll have another look to see why the view wasn't locked, as this method is called from the main Tracker application thread.

comment:8 by aldeck, 11 years ago

Resolution: duplicate
Status: assignedclosed

duplicate of #2571

Note: See TracTickets for help on using tickets.