Opened 11 years ago

Closed 10 years ago

#2898 closed bug (fixed)

Booting from USB fails.

Reported by: richienyhus Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by axeld)

This is from hrev27770, but I still get it in hrev28270

Welcome to Kernel Debugging Land...
Thread 99 "AddOnMonitor" running on CPU 0
kdebug> bt
stack trace for thread 99 "AddOnMonitor"
    kernel stack: 0x922cd000 to 0x922d1000
      user stack: 0x700c3000 to 0x70103000
frame            caller     <image>:function + offset
 0 922cff34 (+  48) 800580a5   <kernel_x86>:invoke_debugger_command + 0x00f5
 1 922cff64 (+  64) 80057e95   <kernel_x86>:invoke_pipe_segment__FP21debugger_co
mmand_pipelPc + 0x0079
 2 922cffa4 (+  64) 8005821d   <kernel_x86>:invoke_debugger_command_pipe + 0x009
d
 3 922cffe4 (+  48) 80059758   <kernel_x86>:_ParseCommandPipe__16ExpressionParse
rRi + 0x0234
 4 922d0014 (+  64) 80058b92   <kernel_x86>:EvaluateCommand__16ExpressionParserP
CcRi + 0x02ba
 5 922d0054 (+ 224) 8005ab80   <kernel_x86>:evaluate_debug_command + 0x0088
 6 922d0134 (+  64) 800564a6   <kernel_x86>:kernel_debugger_loop__Fv + 0x01ae
 7 922d0174 (+  48) 80057079   <kernel_x86>:kernel_debugger + 0x0121
 8 922d01a4 (+ 192) 80056f4d   <kernel_x86>:panic + 0x0029
 9 922d0264 (+  96) 8002bf1c   <kernel_x86>:get_cached_block__FP11block_cachexPb
b + 0x015c
10 922d02c4 (+  80) 8002ee86   <kernel_x86>:block_cache_get_etc + 0x004e
11 922d0314 (+  64) 807a784d   <bfs>:SetTo__11CachedBlockx + 0x0065
12 922d0354 (+  96) 807a30bf   <bfs>:bfs_get_vnode__FP9fs_volumexP8fs_vnodePiPUl
b + 0x0117
13 922d03b4 (+  80) 8008c4f8   <kernel_x86>:get_vnode__FlxPP5vnodebi + 0x0168
14 922d0404 (+  80) 80090063   <kernel_x86>:get_vnode + 0x003f
15 922d0454 (+  64) 807a3bff   <bfs>:bfs_lookup__FP9fs_volumeP8fs_vnodePCcPx + 0
x017f
16 922d0494 (+  80) 8008db58   <kernel_x86>:lookup_dir_entry__FP5vnodePCcPP5vnod
e + 0x0264
17 922d04e4 (+  80) 8008dd6b   <kernel_x86>:vnode_path_to_vnode__FP5vnodePcbiP10
io_contextPP5vnodePx + 0x0173
18 922d0534 (+  96) 8008df57   <kernel_x86>:vnode_path_to_vnode__FP5vnodePcbiP10
io_contextPP5vnodePx + 0x035f
19 922d0594 (+  48) 8008e05d   <kernel_x86>:vnode_path_to_vnode__FP5vnodePcbiT2P
P5vnodePx + 0x0049
20 922d05c4 (+  64) 8008e15c   <kernel_x86>:path_to_vnode__FPcbPP5vnodePxT1 + 0x
00f8
21 922d0604 (+  64) 8008e1a3   <kernel_x86>:path_to_dir_vnode__FPcPP5vnodeT0b +
0x003b
22 922d0644 (+  48) 8008e1ec   <kernel_x86>:fd_and_path_to_dir_vnode__FiPcPP5vno
deT1b + 0x0040
23 922d0674 (+ 320) 80092bb5   <kernel_x86>:file_create__FiPciib + 0x0031
24 922d07b4 (+  80) 800970c0   <kernel_x86>:_kern_open + 0x0098
25 922d0804 (+  48) 800d11f1   <kernel_x86>:open + 0x0029
26 922d0834 (+ 208) 922eb569   </boot/beos/system/add-ons/kernel/drivers/dev/inp
ut/usb_hid>:MakeHIDDevice__9HIDDeviceUlPC22usb_configuration_infoUl + 0x0155
27 922d0904 (+  64) 922eacfa   </boot/beos/system/add-ons/kernel/drivers/dev/inp
ut/usb_hid>:usb_hid_device_added + 0x0142
28 922d0944 (+  80) 8090446b   <usb>:ReportDevice__6DeviceP22usb_support_descrip
torUlPC16usb_notify_hooksPP17usb_driver_cookiebT5 + 0x02af
29 922d0994 (+  64) 80807f18   <ohci>:ReportDevice__3HubP22usb_support_descripto
rUlPC16usb_notify_hooksPP17usb_driver_cookiebT5 + 0x0094
30 922d09d4 (+  64) 8090319d   <usb>:InstallNotify__5StackPCcPC16usb_notify_hook
s + 0x00b5
31 922d0a14 (+  48) 809017e8   <usb>:install_notify__FPCcPC16usb_notify_hooks +
0x002c
32 922d0a44 (+  48) 922eb165   </boot/beos/system/add-ons/kernel/drivers/dev/inp
ut/usb_hid>:init_driver + 0x00bd
33 922d0a74 (+  48) 8006ab39   <kernel_x86>:load_driver__FP13legacy_driver + 0x0
139
34 922d0aa4 (+ 128) 8006b0ad   <kernel_x86>:add_driver__FPCcl + 0x022d
35 922d0b24 (+  32) 8006cf20   <kernel_x86>:legacy_driver_add + 0x0014
36 922d0b44 (+  48) 8006c5fc   <kernel_x86>:try_drivers__FRt16DoublyLinkedList2Z
12driver_entryZt31DoublyLinkedListStandardGetLink1Z12driver_entry + 0x00a4
37 922d0b74 (+ 192) 8006ca4b   <kernel_x86>:probe_for_drivers__FPCc + 0x03ff
38 922d0c34 (+ 144) 8006d1ba   <kernel_x86>:legacy_driver_probe + 0x0172
39 922d0cc4 (+  96) 80064455   <kernel_x86>:scan_for_drivers__FP11devfs_vnode +
0x0085
40 922d0d24 (+  64) 80065499   <kernel_x86>:devfs_lookup__FP9fs_volumeP8fs_vnode
PCcPx + 0x0061
41 922d0d64 (+  80) 8008db58   <kernel_x86>:lookup_dir_entry__FP5vnodePCcPP5vnod
e + 0x0264
42 922d0db4 (+  80) 8008dd6b   <kernel_x86>:vnode_path_to_vnode__FP5vnodePcbiP10
io_contextPP5vnodePx + 0x0173
43 922d0e04 (+  48) 8008e05d   <kernel_x86>:vnode_path_to_vnode__FP5vnodePcbiT2P
P5vnodePx + 0x0049
44 922d0e34 (+  64) 8008e15c   <kernel_x86>:path_to_vnode__FPcbPP5vnodePxT1 + 0x
00f8
45 922d0e74 (+  64) 8008e99c   <kernel_x86>:fd_and_path_to_vnode__FiPcbPP5vnodeP
xT2 + 0x0064
46 922d0eb4 (+  80) 80092d24   <kernel_x86>:file_open__FiPcib + 0x0044
47 922d0f04 (+  64) 8009846d   <kernel_x86>:_user_open + 0x00a1
48 922d0f44 (+ 100) 800c8002   <kernel_x86>:handle_syscall + 0x00af
user iframe at 0x922d0fa8 (end = 0x922d1000)
 eax 0x60           ebx 0x460064        ecx 0x70102a40   edx 0xffff0104
 esi 0x70102b28     edi 0x0             ebp 0x70102a6c   esp 0x922d0fdc
 eip 0xffff0104  eflags 0x206      user esp 0x70102a40
 vector: 0x63, error code: 0x0
49 922d0fa8 (+   0) ffff0104   <commpage>:commpage_syscall + 0x0004
50 70102a6c (+  48) 0039b94e   <libbe.so>:SetTo__10BDirectoryPCc + 0x002a
51 70102a9c (+  48) 0039b595   <libbe.so>:__10BDirectoryPCc + 0x0055
52 70102acc (+ 224) 005d66c3   <keyboard>:_RecursiveScan__19KeyboardInputDeviceP
Cc + 0x0037
53 70102bac (+  48) 005d5533   <keyboard>:InitCheck__19KeyboardInputDevice + 0x0
037
54 70102bdc (+ 112) 00217926   <_APP_>:RegisterAddOn__12AddOnManagerR6BEntry + 0
x011e
55 70102c4c (+ 128) 0021ae69   <_APP_>:AddOnEnabled__Q212AddOnManager25InputServ
erMonitorHandlerPCQ38BPrivate7Storage17add_on_entry_info + 0x0069
56 70102ccc (+ 528) 00221348   <_APP_>:HandlePulse__Q38BPrivate7Storage19AddOnMo
nitorHandler + 0x0520
57 70102edc (+  48) 0021f26c   <_APP_>:MessageReceived__Q38BPrivate7Storage19Add
OnMonitorHandlerP8BMessage + 0x002c
58 70102f0c (+  48) 002db11f   <libbe.so>:DispatchMessage__7BLooperP8BMessageP8B
Handler + 0x005b
59 70102f3c (+  64) 002dca8d   <libbe.so>:task_looper__7BLooper + 0x0211
60 70102f7c (+  48) 002dc67b   <libbe.so>:_task0___7BLooperPv + 0x003f
61 70102fac (+  48) 004d77cc   <libroot.so>:_get_next_team_info + 0x005c (neares
t)
62 70102fdc (+   0) 70102fec   3974:AddOnMonitor_99_stack@0x700c3000 + 0x3ffec
kdebug>

Attachments (3)

haikutest.txt (9.8 KB) - added by richienyhus 11 years ago.
stacktrace1
haikutest2.txt (24.0 KB) - added by richienyhus 11 years ago.
stacktrace2
haikutest3.TXT (11.1 KB) - added by richienyhus 10 years ago.
hrev28781

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by richienyhus

Attachment: haikutest.txt added

stacktrace1

Changed 11 years ago by richienyhus

Attachment: haikutest2.txt added

stacktrace2

comment:1 Changed 11 years ago by richienyhus

oh yeah this is on a albatron KM51G-754. And also my ticket #2780 shows that this problem wasn't in hrev27764.

comment:2 Changed 11 years ago by axeld

Component: Add-OnsDrivers/USB
Description: modified (diff)
Owner: changed from axeld to mmlr
Summary: AddOnMonitor crashs haiku after bootBooting from USB fails.

You're obviously booting from USB, and usb_disk returns several errors until it finally finds the way into KDL.

comment:3 Changed 10 years ago by richienyhus

Still get this regression in hrev28781

comment:4 Changed 10 years ago by richienyhus

Its looks like either hrev27765, hrev27766 or(and more likely) hrev27768 created this regression.

comment:5 Changed 10 years ago by mmlr

No, I highly doubt that these changes would cause anything in that direction. They do not change any functionality. I personally suspect hrev28244 as it triggered other issues with USB as well. If you could check with hrev28243 vs. hrev28244 that would be helpful. Are you running a dual core machine by any chance? Does this also happen when you disable SMP in the safemode menu?

comment:6 Changed 10 years ago by richienyhus

This is only a AMD sempron 2660+ on an Albatron KM51G-754.

I don't have a build set-up so I can only try hrev28242 & hrev28251.

Changed 10 years ago by richienyhus

Attachment: haikutest3.TXT added

comment:7 Changed 10 years ago by richienyhus

I only had a USB keyboard plugged in before, so I didn't test with "bt". I just checked then and it seems as if the error has changed. Some of the out-put looks same, so I'll keep this here 'til someone can tell otherwise.

comment:8 Changed 10 years ago by mmlr

Status: newassigned

Can you please retry with a current revision (>= hrev28934)? In case of an error, the device couldn't ever recover because of a bug fixed in hrev28929 and an error could've been provoked by another bug fixed in revisions up to hrev28934.

comment:9 Changed 10 years ago by richienyhus

I'll have a look with a vision post hrev28934, that is when there is a new Pre Alpha image.

comment:10 Changed 10 years ago by richienyhus

This can be closed, its fixed now.

Cheers!

comment:11 Changed 10 years ago by mmlr

Resolution: fixed
Status: assignedclosed

Great, thanks for the feedback!

Note: See TracTickets for help on using tickets.