Opened 11 years ago

Closed 9 years ago

#2911 closed bug (fixed)

vm_page_fault: unhandled page fault in kernel space at 0xcccccccc, ip 0x80049b42

Reported by: stippi Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It all started because Tracker crashed. I wanted to open the Home folder by double-clicking onto the link on the Desktop. Somehow I dragged and opened the context menu for the link instead (almost at the same time), because I needed to use the graphics tablet. My other USB devices stopped working again, but the tablet usually still works in this situation. Anyways, it's hard to perform any clicks at all with a tablet while not moving the pen at the same time. (On a related note, it's almost impossible to open links in NetSurf because of the movement while clicking). So Tracker crashed in the BPopUpMenu tracking thread when it opens the window and tries to attach the BMenuBar (enters debugger because it's already attached). After I had seen enough in GDB, I typed "detach" and that dropped me right into KDL, with this stack trace:

[...]
<kernel_x86>:vm_page_fault + 0x0199
<kernel_x86>:page_fault_exception + 0x00d4
<kernel_x86>:int_bottom + 0x0036
kernel iframe at 0x88d5fed0 (end = 0x88d5ff20)
 eax 0xcccccccc  ebx 0x78206fe0    ecx 0x0          edx 0x8516c800
 esi 0x800       edi 0x0           ebp 0x88d5ff68   esp 0x88d5ff04
 eip 0x80049b42 eflags 0x10206
 vector: 0xe, error code: 0x0
<kernel_x86>:handle_signals + 0x0066
<kernel_x86>:thread_at_kernel_exit + 0x0085
<kernel_x86>:arch_thread_enter_userspace + 0x0066
<kernel_x86>:_create_user_thread_kentry() + 0x0024
<kernel_x86>:thread_kthread_exit() + 0x0000

If I should type more of the numbers for it to be more helpful next time, please tell...

Change History (5)

comment:1 Changed 11 years ago by stippi

Summary: vm_page_fault: unhandled page fault in kernel space at 9xcccccccc, ip 0x80049b42vm_page_fault: unhandled page fault in kernel space at 0xcccccccc, ip 0x80049b42

comment:2 Changed 11 years ago by bonefish

What thread is it? Apparently some newly-created userland thread. For later reference the revision number would be good, too.

In my build handle_signals() + 0x66 doesn't hit an instruction, so you've apparently built with other parameters. An objdump of handle_signals() would be helpful (can be done on your build platform: objdump -D --demangle .../kernel_x86; copy only handle_signals() part).

comment:3 Changed 11 years ago by stippi

I have since updated and rebuild with other options (various tracing options turned on)... sorry for not providing the revision, that was stupid.

comment:4 Changed 9 years ago by bonefish

Component: - GeneralSystem/Kernel

No idea what to do with this ticket. Without more information or a way to reproduce it, there's no way to analyze it. If it still exists at all that is.

I recall having seen crashes in handle_signals() from time to time (relatively rarely, though), but the last time was ages ago. So that might have been the side effect of some seemingly unrelated bug (e.g. overwriting of stack as fixed in hrev34655).

comment:5 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

I'd say let's close this ticket. I have never seen anything like that again and as you say, the chances of this being caused by another bug that has been fixed meanwhile are great.

Note: See TracTickets for help on using tickets.