Opened 11 years ago

Closed 11 years ago

#2913 closed bug (fixed)

crash in "usb explore" thread a short while after switching USB KVM forth and back

Reported by: stippi Owned by: mmlr
Priority: high Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

My KVM connected keyboard stopped working, while my mouse was still working fine. This is different from the regular problems I get with both devices suddenly going dead. So I tried to recover the keyboard by switching my KVM to another computer and back. It didn't work, instead the mouse was dead as well. I had enough time to type some letters with the also connected PS/2 keyboard, then I was suddenly in KDL:

vm_page_fault: unhandled page fault in kernel space at 0xc, ip 0x807e9b40

[...]
<kernel_x86>:panic
<kernel_x86>:vm_page_fault
<kernel_x86>:int_bottom
kernel iframe at 0x802c8de0 (end = 0x802c8e30)
 eax 0x0            ebx 0x8102d300   ecx 0x2          edx 0x3
 esi 0x802c8eac     edi 0xc          ebp 0x802c8e58   esp 0x802c8e14
 eip 0x807e9b40  eflags 0x21026
 vector: 0xe, error code: 0x0
<usb>:_._6Device + 0x004c
<usb>:BusManager<0x81019a44>::AllocateDevice(Hub*: 0x81029bb0, 0x0, uint8: 0xff (255), usb_speed: 0x0) + 0x030c
<usb>: Hub<0x81029bb0>::Explore(change_item*: 0x802c8fd4) + 0x018e
<usb>: Hub<0x81029660>::Explore(change_item*: 0x802c8fd4) + 0x03bd
<usb>: Stack<0x8103c5f0>::ExploreThread(NULL) + 0x0059
[...]

Change History (2)

comment:1 by stippi, 11 years ago

It's been a long time, and I cannot reproduce this anymore. Feel free to close.

comment:2 by mmlr, 11 years ago

Resolution: fixed
Status: newclosed

Ok, thanks for the feedback!

Note: See TracTickets for help on using tickets.