Opened 11 years ago

Closed 9 years ago

#2920 closed bug (fixed)

[app_server] deadlock while trying to close windows

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tested with hrev28302 in VirtualBox.

Steps to reproduce:

*Boot Haiku

*Select desktop

*Press alt+f to launch find window of tracker

*Hit return and wait until it finds all possible objects (about 3880)

*Press Alt+a to select all

*Hit return and wait until every folder will open (note that only folders will be open)

*Hold down Alt+w to start closing all opened folders (notice that only first two folders would close this way, another bug?)

*Repeat with Alt+w and close another 10-20 folders until app_server deadlock.

Change History (2)

comment:1 Changed 9 years ago by diver

Can't reproduce it in hrev38300 in vbox. Feel free to close.

comment:2 Changed 9 years ago by anevilyak

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.