Opened 11 years ago

Closed 10 years ago

#2924 closed bug (fixed)

vlc causes "Segmentation violation" sometimes

Reported by: umccullough Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using hrev28290, I can generate this "Segmentation violation" error in a Terminal by running vlc repeatedly (usually fails within 2 or 3 tries).

Example (success first time, failure second time):

/boot/apps/vlc-0.8.6c> vlc
VLC media player 0.8.6c Janus
scrollview BView::InitData(): resizing mode or flags swapped
/boot/apps/vlc-0.8.6c> vlc
VLC media player 0.8.6c Janus
Segmentation violation
/boot/apps/vlc-0.8.6c>

Only seems to be repeatable when both cores are enabled, when only a single core enabled (by disabling one with pulse), I cannot make it occur.

Quick machine specs: Core 2 Duo E6850 (2.66ghz), 4gb RAM, 500gb SATA disk (using ata bus_manager), intel G33 video, rtl8168 network

I ran with strace to generate the attached output with failure.

Attachments (1)

vlc_seg_violation.txt (11.2 KB ) - added by umccullough 11 years ago.
vlc Segmentation violation

Download all attachments as: .zip

Change History (4)

by umccullough, 11 years ago

Attachment: vlc_seg_violation.txt added

vlc Segmentation violation

comment:1 by umccullough, 11 years ago

I am now unable to reproduce this issue currently, on the same hardware as before.

I suspect possibly it was fixed by hrev28051 but I will revert back to 28050 and test again to make sure.

Unfortunately that machine is busy with another task, but I will try to test again tonight.

comment:2 by umccullough, 10 years ago

This has not been an issue since hrev29051 (ignore previous comment, that mentions the wrong revision).

Please close as fixed.

comment:3 by umccullough, 10 years ago

Component: System/libroot.soSystem/Kernel
Resolution: fixed
Status: newclosed

Duh, I have permissions :P

Note: See TracTickets for help on using tickets.