Opened 11 years ago

Closed 2 years ago

Last modified 10 months ago

#2926 closed bug (no change required)

Gobe Prod. crashes when fast mouse movement over fill tabs

Reported by: nutela Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14209
Has a Patch: no Platform: All

Description

  • how to reproduce

Start GP ver2.x choose vector graphics, click on the fill icon and quickly go with the mouse over the tiny tabs (colour, texture, gradient, opacity)

  • experienced behavior

GP crashes immediately and reproducibly

  • expected behavior

GP shouldn't crash because it doesn't in R5 with the same steps to reproduce.

Not sure under which Component to put, therefor put to "General"

Change History (7)

comment:1 Changed 11 years ago by stippi

Please provide a stack crawl. When the crash alert pops up, click on Details, then Debugger and in the debugger terminal, enter the command "bt". Then copy and paste the output here. Please always include this information when something crashes.

comment:2 Changed 4 years ago by diver

	thread 835: TMenuElementPopUp 
		state: Exception (Segment violation)

		Frame		IP			Function Name
		-----------------------------------------------
		00000000	00000000	? 
			Frame memory:
				
		0x1981d818	0x11f87b4	TRibbonElement::Draw(bool) + 0x5c 
		0x000004	0x000009	? 

Looks like an application bug to me. I wonder why it works in BeOS then...

comment:3 Changed 4 years ago by diver

Platform: x86All
Version: R1/pre-alpha1R1/Development

comment:4 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:5 Changed 2 years ago by diver

Resolution: no change required
Status: assignedclosed

comment:6 Changed 2 years ago by Giova84

Sorry for commenting on a closed ticket. I also have Gobe Productive on my sistem: by doing "click on the fill icon and quickly go with the mouse over the tiny tabs (colour, texture, gradient, opacity)" this time GB doesn't crash, but however will completely hangs and is impossible to close it: I have to kill it using SHIFT+CONTROL+ALT from its icon in the Deskbar.

comment:7 Changed 10 months ago by diver

Blocking: 14209 added
Note: See TracTickets for help on using tickets.