Opened 10 years ago

Closed 9 years ago

#2955 closed bug (fixed)

using multiple USB HIDs not possible, USB input devices stop working

Reported by: nutela Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/Mouse/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

how to reproduce, experienced behavior: logitech wireless keyboard and mouse plugged in directly and a wacom graphire4 tablet plugged in via usb hub. Made mouse movement, then moved pen over tablet=ok, move both at the same time->mouse stops moving cursor, use pen->cursor moves ok, switch back to mouse movement->cursor moves slightly then stops responding, is reproducible, this behaviour > 6 months BUT now: unplug wacom->KDL

expected behavior: able to use cursor with multiple input devices, should not KDL :-)

Hope set right component.

Attachments (5)

bt1.jpg (304.4 KB) - added by nutela 10 years ago.
kdl bt screenshot
syslog (7.0 KB) - added by nutela 10 years ago.
syslog;better format sorry for pasting it into comment
syslog28353 (5.2 KB) - added by nutela 10 years ago.
Obraz060[1] (290.2 KB) - added by nutela 10 years ago.
backtrace - KDE after wacom and composit HID device
Obraz062[1] (282.4 KB) - added by nutela 10 years ago.
backtrace KDL during boot, Genius USB keyb Slimstar KKB-2050U

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by nutela

Attachment: bt1.jpg added

kdl bt screenshot

comment:1 Changed 10 years ago by nutela

This happens when I plug in my wacom tablet on rev 28339 (haven't had kdl anymore): KERN: wacom: add_device() - wacom detected KERN: wacom: ... success! KERN: void AddOnManager::MessageReceived(BMessage *) what: NMP_ KERN: wacom: device_open() open: 2 KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 3: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: USB ControlPipe: timeout waiting for queued request to complete KERN: USB Hub 2: error updating port status KERN: usb_uhci: td (0x0234bb80) error: status: 0x254507ff; token: 0x00e88569; KERN: wacom: interrupt transfer - failure: -2147442668 KERN: usb_uhci: td (0x0234bec0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234bf00) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234c240) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234c280) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234c5c0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234c600) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234c940) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234c980) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234ccc0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234cd00) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d040) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d080) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d3c0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d400) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d480) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d4a0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d520) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d540) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d5c0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d5e0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d660) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d680) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d700) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d720) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d7a0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d7c0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d840) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d860) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d8e0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d900) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d920) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d940) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d9c0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234d9e0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234da60) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234da80) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234db00) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234db20) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dba0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dbc0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dc80) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dca0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dd20) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dd40) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234ddc0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dde0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234de60) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234de80) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dea0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dec0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234df40) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234df60) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234dfe0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234e000) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234e080) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234b780) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234b7c0) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234bb00) error: status: 0x254507ff; token: 0x00e88569; KERN: usb_uhci: td (0x0234bb40) error: status: 0x254507ff; token: 0x00e88569; KERN: wacom: device_removed() open: 1 KERN: wacom: device /dev/input/wacom/usb/0 still open -- marked for removal KERN: void AddOnManager::MessageReceived(BMessage *) what: NMP_

Changed 10 years ago by nutela

Attachment: syslog added

syslog;better format sorry for pasting it into comment

comment:2 Changed 10 years ago by jackburton

Which revision is this ? In case it's older than hrev28342, can you try to update ?

comment:3 Changed 10 years ago by nutela

Same problem persists; after using both the wacom tablet and mouse to control the cursor the mouse stops moving the cursor, messages appear in syslog, see attachment, rev 28353

Changed 10 years ago by nutela

Attachment: syslog28353 added

comment:4 Changed 10 years ago by nutela

Summary: KDL wacom tablet unlugged: AddOnManager?using multiple USB HIDs not possible, USB input devices stop working

Changed summary because after rev 28353 no KDL. Not sure if Component still set correctly, tell me if I should update too

comment:5 Changed 10 years ago by korli

Component: Add-Ons/Input MethodsDrivers/Mouse/USB
Owner: changed from korli to mmlr

Changed 10 years ago by nutela

Attachment: Obraz060[1] added

backtrace - KDE after wacom and composit HID device

Changed 10 years ago by nutela

Attachment: Obraz062[1] added

backtrace KDL during boot, Genius USB keyb Slimstar KKB-2050U

comment:6 Changed 10 years ago by nutela

the above was in rev 28858 and also happens in rev 28859

comment:7 Changed 10 years ago by mmlr

Please check with the reworked usb_hid driver in hrev31790 and up.

comment:8 Changed 9 years ago by mmlr

Please retry with a current revision and update this report. Otherwise I'd like to close this. The usb_hid driver has been reworked, numerous other bugs have been fixed as well.

comment:9 Changed 9 years ago by mmlr

Resolution: fixed
Status: newclosed

Closing since no further updates. The usb_hid has been reworked which most likely fixed this.

Note: See TracTickets for help on using tickets.