Opened 10 years ago

Last modified 3 years ago

#2997 new bug

Regression: DrawingEngine::ReadBitmap copies the cursor always into the bitmap (does not respect cursor on off setting)

Reported by: julun Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This regression was introduced with hrev24346, first only visible while using VESA mode, now also with real drivers because the use double buffering as well. To verify use Magnify or Screenshot.

Change History (5)

comment:1 Changed 10 years ago by axeld

Milestone: R1/alpha1R1
Priority: highnormal

Hardly a R1/alpha candidate.

comment:2 Changed 10 years ago by stippi

BTW, so that it is not forgotten, I have a "fix" for this locally, but while it works very fine in the app_server test environment and probably in VESA mode, it is a weird problem when using the nVidia driver, which I cannot explain myself....

comment:3 in reply to:  2 Changed 9 years ago by jackburton

Replying to stippi:

BTW, so that it is not forgotten, I have a "fix" for this locally, but while it works very fine in the app_server test environment and probably in VESA mode, it is a weird problem when using the nVidia driver, which I cannot explain myself....

Ping! Any news on this ? At least, please show us the fix :-)

comment:4 Changed 9 years ago by Wim

Blocking: 2988 removed

comment:5 Changed 3 years ago by diver

Version: R1/pre-alpha1R1/Development

ping

Note: See TracTickets for help on using tickets.