Opened 11 years ago

Last modified 4 years ago

#2997 new bug

Regression: DrawingEngine::ReadBitmap copies the cursor always into the bitmap (does not respect cursor on off setting)

Reported by: julun Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This regression was introduced with hrev24346, first only visible while using VESA mode, now also with real drivers because the use double buffering as well. To verify use Magnify or Screenshot.

Change History (5)

comment:1 by axeld, 11 years ago

Milestone: R1/alpha1R1
Priority: highnormal

Hardly a R1/alpha candidate.

comment:2 by stippi, 11 years ago

BTW, so that it is not forgotten, I have a "fix" for this locally, but while it works very fine in the app_server test environment and probably in VESA mode, it is a weird problem when using the nVidia driver, which I cannot explain myself....

in reply to:  2 comment:3 by jackburton, 10 years ago

Replying to stippi:

BTW, so that it is not forgotten, I have a "fix" for this locally, but while it works very fine in the app_server test environment and probably in VESA mode, it is a weird problem when using the nVidia driver, which I cannot explain myself....

Ping! Any news on this ? At least, please show us the fix :-)

comment:4 by Wim, 9 years ago

Blocking: 2988 removed

comment:5 by diver, 4 years ago

Version: R1/pre-alpha1R1/Development

ping

Note: See TracTickets for help on using tickets.