Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3005 closed bug (fixed)

SoundRecorder records only few seconds by default

Reported by: nutela Owned by: korli
Priority: normal Milestone: R1
Component: Applications/SoundRecorder Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

# how to reproduce Press record and don't press stop # experienced behavior After a few seconds (10?) SoundRecorder stops recording, time is not displayed # expected behavior SoundRecorder should record to buffer on hard disk drive until hdd is full, the elapsed time should be displayed

Change History (7)

comment:1 by korli, 11 years ago

Default record time is 8 seconds: you can change it in the bottom part (hidden at first).

comment:2 by axeld, 11 years ago

But isn't that a bit unintuitive?

comment:3 by korli, 11 years ago

Dunno, this is typical for recording applications to provide a max record time. I think the BeOS SoundRecorder behaves the same.

in reply to:  3 comment:4 by nutela, 11 years ago

Summary: SoundRecorder records only few secondsSoundRecorder records only few seconds by default

Replying to korli:

Dunno, this is typical for recording applications to provide a max record time. I think the BeOS SoundRecorder behaves the same.

No it does not, there is no limit displayed in the GUI of R5's SoundRecorder. Why is there a limit? Does it record to RAM? What could be done is have it disabled with a check box to enable it because I think it is not a bad feature at all. I can set this bug to "enhancement" is that desirable?

comment:5 by stippi, 11 years ago

I'd also vote for putting a checkmark in front the limit text box and to turn it off by default (unlimited recording time), especially since the limit text box is hidden in the default interface.

comment:6 by korli, 11 years ago

Resolution: fixed
Status: newclosed

I removed the record time limit in hrev28505.

comment:7 by nutela, 11 years ago

verified thanks! Still a limit setting is not a bad idea.

Note: See TracTickets for help on using tickets.