Opened 11 years ago

Closed 6 months ago

#3024 closed bug (fixed)

address space deadlock when launching application (WonderBrush)

Reported by: stippi Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: address_space Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Trying to track down an Interface Kit bug, I had linked the libbe.so from the generated folder into the WonderBrush lib subfolder and I repeatedly launched WonderBrush with a new build of libbe.so. At one point, WonderBrush would not come up, but just sit there half-started. The rest of the system continued just fine as if nothing happened. I manually entered KDL and took a look a the WonderBrush threads. They seemed to dead lock on the address space rw_lock, but I could not see who was the holder of the lock. I have taken screen shots with a camera. Hopefully I will be able to attach them...

This may be a duplicate of #2710, unless that one is about freezing the entire system. That was not the case for me, I could even shutdown "normally", although WonderBrush was obviously unkillable.

Change History (4)

comment:1 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:2 by tqh, 21 months ago

Keywords: address_space added

comment:3 by waddlesplash, 6 months ago

Still reproducible?

comment:4 by stippi, 6 months ago

Resolution: fixed
Status: assignedclosed

Very likely not. :-) I still use WonderBrush very often, and it never locked up in years.

Note: See TracTickets for help on using tickets.