Opened 14 years ago

Closed 12 years ago

#303 closed bug (fixed)

Haikus boundingboxes seemes to be broken (when you rotate fonts)

Reported by: mikael.konradson@… Owned by: mmlr
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by mmlr)

Haiku's versions of GetBoundingBoxesAs*/ForStrings workes only for non rotated fonts. (Or atleast the fontdemos version is broken).

Steps to reproduce:

  1. Start FontDemo (copy from R5)
  2. Check Bounding boxes
  3. Rotate string to see the bug

/Konrad

Change History (5)

comment:1 by axeld, 14 years ago

Owner: changed from bpmagic@… to mmlr

comment:2 by axeld, 14 years ago

If you find the time :-)

comment:3 by diver, 14 years ago

Cc: diver added

comment:4 by aldeck, 12 years ago

Platform: All

Bounding boxes are correct since a few revisions (testing on hrev21836), bug should be closed.

There's a new bug that would deserve a separate ticket : shear and rotation not working, then working again, after a changing the font. But i know this area is in active development so i'll wait and see.

comment:5 by mmlr, 12 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed

closing as per comment above.

Note: See TracTickets for help on using tickets.