Opened 11 years ago

Closed 11 years ago

#3030 closed bug (invalid)

[Playground] font corruption

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Start Playground and draw line above "Click and drag to draw an object".
Then change Mode to "Select"

Attachments (1)

playground.png (49.6 KB ) - added by diver 11 years ago.

Download all attachments as: .zip

Change History (3)

by diver, 11 years ago

Attachment: playground.png added

comment:1 by mmlr, 11 years ago

Owner: changed from axeld to stippi

That is actually expected behaviour. The B_OP_SELECT mode switches the high with the low color where the source is not transparent/has the low color. The source is straight high color (blue) and the low color is the background gray. Since B_OP_SELECT only affects the exactly matching low color, the antialiasing of the font isn't taken into account. I think there is no way of changing that without changing the meaning of B_OP_SELECT itself. See The BeBook text for reference to B_OP_SELECT. I'll leave it to Stephan to decide on that one though.

comment:2 by stippi, 11 years ago

Resolution: invalid
Status: newclosed

Yes, Michael is right.

Note: See TracTickets for help on using tickets.