Opened 10 years ago

Closed 10 years ago

#3070 closed bug (fixed)

[SoundRecorder] crash if you drop unknown file to it twice

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: Applications/SoundRecorder Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Open SoundRecorder and drop Welcome link from desktop to it window.
After error drop this file again and SoundRecorder will crash

Attachments (1)

soundrecorder.png (104.9 KB) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by diver

Attachment: soundrecorder.png added

comment:1 Changed 10 years ago by korli

Resolution: fixed
Status: newclosed

fixed in hrev28569

comment:2 Changed 10 years ago by diver

Resolution: fixed
Status: closedreopened

I still can crash SoundRecorder if I drop any BeApplication (like People) on it.

comment:3 Changed 10 years ago by korli

Please check again with hrev28613.

comment:4 Changed 10 years ago by diver

Now it tries to extract audio info from BeApplication for about 5 seconds, but don't crash.

comment:5 Changed 10 years ago by diver

Can't reproduce it anymore in VirtualBox 3.0.4

comment:6 Changed 10 years ago by modeenf

Resolution: fixed
Status: reopenedclosed

Tested in hrev32893 with real hardware without this problem. Closing this ticket.

Note: See TracTickets for help on using tickets.