Opened 11 years ago

Closed 7 years ago

#3075 closed bug (fixed)

[Tracker] crash in BList::ItemAt ()

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc: Diger
Blocked By: Blocking: #5402, #8089
Has a Patch: no Platform: All

Description


Attachments (1)

deskbar.png (134.5 KB ) - added by diver 11 years ago.

Download all attachments as: .zip

Change History (15)

by diver, 11 years ago

Attachment: deskbar.png added

comment:1 by diver, 11 years ago

I was trying to reproduce #3076 and accidentally moved cursor to Applications item and then it crashed.

comment:2 by diver, 11 years ago

Summary: Deskbar crash in BList::ItemAt[Deskbar] crash in BList::ItemAt

comment:3 by diver, 11 years ago

Ok, I could reproduce it with just dragging Home link frome Desktop above folders in Leaf menu.

comment:4 by diver, 10 years ago

Summary: [Deskbar] crash in BList::ItemAt[Deskbar] crash in BList::ItemAt ()

comment:5 by diver, 10 years ago

Version: R1/pre-alpha1R1/Development

Still here in hrev35572.

comment:6 by diver, 9 years ago

Still reproducible in hrev38300.

comment:7 by diver, 8 years ago

Blocking: 8089 added

comment:8 by diver, 8 years ago

Blocking: 5402 added

comment:9 by diver, 7 years ago

Still here in hrev44257.

comment:10 by diver, 7 years ago

Cc: Diger added
Component: Applications/DeskbarApplications/Tracker

Dragging html files over Haiku->apps drill down menu triggers this crash.

Thread 235 caused an exception: Segment violation
[...]
[Switching to team /boot/system/Tracker (113) thread popup (235)]
0x004440fe in BList::ItemAt () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x004440fe in BList::ItemAt () from /boot/system/lib/libbe.so
#1  0x0060df24 in long WhileEachListItem<BString, long, char const *> () from /boot/system/lib/libtracker.so
#2  0x0060cf22 in BPrivate::Model::SupportsMimeType () from /boot/system/lib/libtracker.so
#3  0x00611a00 in BPrivate::SpringLoadedFolderSetMenuStates () from /boot/system/lib/libtracker.so
#4  0x006125f8 in BPrivate::BNavMenu::AttachedToWindow () from /boot/system/lib/libtracker.so
#5  0x003bedec in BView::_Attach () from /boot/system/lib/libbe.so
#6  0x003bb7b1 in BView::_AddChild () from /boot/system/lib/libbe.so
#7  0x003bb645 in BView::AddChild () from /boot/system/lib/libbe.so
#8  0x0036198f in BPrivate::BMenuFrame::AttachedToWindow () from /boot/system/lib/libbe.so
#9  0x003bedec in BView::_Attach () from /boot/system/lib/libbe.so
#10 0x003bb7b1 in BView::_AddChild () from /boot/system/lib/libbe.so
#11 0x003bb645 in BView::AddChild () from /boot/system/lib/libbe.so
#12 0x003c1afb in BWindow::AddChild () from /boot/system/lib/libbe.so
#13 0x00361fc3 in BPrivate::BMenuWindow::AttachMenu () from /boot/system/lib/libbe.so
#14 0x00355244 in BMenu::_Show () from /boot/system/lib/libbe.so
#15 0x00357ddc in BMenu::_SelectItem () from /boot/system/lib/libbe.so
#16 0x0035615c in BMenu::_UpdateStateOpenSelect () from /boot/system/lib/libbe.so
#17 0x00355846 in BMenu::_Track () from /boot/system/lib/libbe.so
#18 0x0035573e in BMenu::_Track () from /boot/system/lib/libbe.so
#19 0x003549c1 in BMenu::Track () from /boot/system/lib/libbe.so
#20 0x0036eb17 in BPopUpMenu::_StartTrack () from /boot/system/lib/libbe.so
#21 0x0036e9fb in BPopUpMenu::_thread_entry () from /boot/system/lib/libbe.so
#22 0x00718703 in thread_entry () from /boot/system/lib/libroot.so
#23 0x781b9fec in ?? ()
(gdb)

comment:11 by diver, 7 years ago

Summary: [Deskbar] crash in BList::ItemAt ()[Tracker] crash in BList::ItemAt ()

comment:12 by anevilyak, 7 years ago

Please try with hrev44608 or later (trunk).

comment:13 by diver, 7 years ago

The crash seems to be gone now (hrev44610), but I noticed a possible regression:
Open /system/documentation/diskusage. Drag DiskUsage.html file over Haiku->system (or any other folder) on the Desktop and then quickly move your mouse away from drill down menu without dropping the file.
At this point Tracker alert with move confirmation appears as if you dropped the file.

comment:14 by anevilyak, 7 years ago

Resolution: fixed
Status: newclosed

That sounds unrelated, possibly a regression of the async mouse tracking rewrites that couldn't be tested until now...please file a new ticket for that one and assign to either me or aldeck.

Note: See TracTickets for help on using tickets.