Opened 11 years ago

Closed 11 years ago

#3092 closed bug (fixed)

trac "View Tickets" doesn't work

Reported by: marcusoverhagen Owned by: nielx
Priority: normal Milestone: R1
Component: Website/Trac Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by nielx)

Oops… Trac detected an internal error:

TemplateNotFound: Template "query_results.html" not found

If you think this should work you can reproduce the problem, you should consider reporting this to the Trac team.

Before you do that, though, please first try searching for similar issues, as it is quite likely that this problem has been reported before. For questions about installation and configuration of Trac, please try the mailing list instead of filing a ticket.

Otherwise, please ==== How to Reproduce ==== While doing a GET operation on /query, Trac issued an internal error. (please provide additional details here) User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 ==== System Information ====
Trac 0.11.1 Python 2.5.1 (r251:54863, Nov 3 2007, 02:54:36) [C] setuptools 0.6c8 psycopg2 2.0.6 Genshi 0.5 Pygments 0.10 Subversion 1.4.5 (r25188) jQuery: 1.2.6 ==== Python Traceback ==== Traceback (most recent call last): File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request dispatcher.dispatch(req) File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 219, in dispatch data, content_type) File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/chrome.py", line 683, in render_template template = self.load_template(filename, method=method) File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/chrome.py", line 667, in load_template return self.templates.load(filename, cls=cls) File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 221, in load filename, encoding=encoding) File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 259, in _instantiate allow_exec=self.allow_exec) File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/base.py", line 377, in __init__ self.stream = list(self._prepare(self._parse(source, encoding))) File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/base.py", line 444, in _prepare cls=cls or self.__class__) File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 231, in load raise TemplateNotFound(filename, search_path) TemplateNotFound: Template "query_results.html" not found a new ticket at the Trac project site, where you can describe the problem and explain how to reproduce it.

Python Traceback Most recent call last:

  • File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request Code fragment:
    1. try:
    2. if not env and env_error:
    3. raise HTTPInternalError(env_error)
    4. try:
    5. dispatcher = RequestDispatcher(env)
    6. dispatcher.dispatch(req)
    7. except RequestDone:
    8. pass
    9. resp = req._response or []
    10. except HTTPException, e:
    Local variables: Name Value after [u' except RequestDone:', u' pass', u' resp = ... before [u' try:', u' if not env and env_error:', u' raise ... dispatcher <trac.web.main.RequestDispatcher object at 0x9aa86cc> e TemplateNotFound(u'Template "query_results.html" not found',) env <trac.env.Environment object at 0x96296ec> env_error None exc_info (<class 'genshi.template.loader.TemplateNotFound'>, ... filename '/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py' frames [{'function': '_dispatch_request', 'lines_before': [u' try:', u' ... has_admin True line u' dispatcher.dispatch(req)' lineno 422 message u'TemplateNotFound: Template "query_results.html" not found' req <Request "GET u'/query'"> resp [] tb <traceback object at 0xb2a2c0c> tb_hide None traceback 'Traceback (most recent call last):\n File ...
  • File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 219, in dispatch Code fragment:
    1. out = StringIO()
    2. pprint(data, out)
    3. req.send(out.getvalue(), 'text/plain')
    4. else:
    5. output = chrome.render_template(req, template,
    6. data, content_type)
    7. # Give the session a chance to persist changes
    8. if req.session:
    9. req.session.save()
    10. req.send(output, content_type or 'text/html')
    Local variables: Name Value chosen_handler <trac.ticket.query.QueryModule object at 0x9aa874c> chrome <trac.web.chrome.Chrome object at 0x9a9afec> content_type None data {'tickets': [{u'status': u'assigned', u'changetime': ... err (<class 'genshi.template.loader.TemplateNotFound'>, ... handler <trac.ticket.query.QueryModule object at 0x9aa874c> req <Request "GET u'/query'"> resp ('query.html', {'tickets': [{u'status': u'assigned', u'changetime': ... self <trac.web.main.RequestDispatcher object at 0x9aa86cc> template 'query.html'
  • File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/chrome.py", line 683, in render_template Code fragment:
    1. if content_type is None:
    2. content_type = 'text/html'
    3. method = {'text/html': 'xhtml',
    4. 'text/plain': 'text'}.get(content_type, 'xml')
    5. template = self.load_template(filename, method=method)
    6. data = self.populate_data(req, data)
    7. stream = template.generate(data)
    8. # Filter through ITemplateStreamFilter plugins
    Local variables: Name Value content_type 'text/html' data {'tickets': [{u'status': u'assigned', u'changetime': ... filename 'query.html' fragment False method 'xhtml' req <Request "GET u'/query'"> self <trac.web.chrome.Chrome object at 0x9a9afec>
  • File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/chrome.py", line 667, in load_template Code fragment:
    1. if method == 'text':
    2. cls = TextTemplate
    3. else:
    4. cls = MarkupTemplate
    5. return self.templates.load(filename, cls=cls)
    6. def render_template(self, req, filename, data, content_type=None,
    7. fragment=False):
    8. """Render the filename using the data for the context.
    Local variables: Name Value cls <class 'genshi.template.markup.MarkupTemplate'> filename 'query.html' method 'xhtml' self <trac.web.chrome.Chrome object at 0x9a9afec>
  • File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 221, in load Local variables: Name Value cachekey 'query.html' cls <class 'genshi.template.markup.MarkupTemplate'> encoding None filename 'query.html' fileobj <closed file ... filepath '/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/ticket/templa ... isabs False loadfunc <function _load_from_directory at 0xad32df4> relative_to None search_path ['/var/trac/dev.haiku-os.org/templates', ... self <genshi.template.loader.TemplateLoader object at 0x989b46c> uptodate <function _uptodate at 0xad32684>
  • File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 259, in _instantiate Local variables: Name Value cls <class 'genshi.template.markup.MarkupTemplate'> encoding None filename 'query.html' fileobj <closed file ... filepath '/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/ticket/templa ... self <genshi.template.loader.TemplateLoader object at 0x989b46c>
  • File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/base.py", line 377, in init Local variables: Name Value allow_exec True encoding None filename 'query.html' filepath '/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/ticket/templa ... loader <genshi.template.loader.TemplateLoader object at 0x989b46c> lookup 'lenient' self <MarkupTemplate "query.html"> source <closed file ...
  • File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/base.py", line 444, in _prepare Local variables: Name Value TemplateNotFound <class 'genshi.template.loader.TemplateNotFound'> cls <class 'genshi.template.markup.MarkupTemplate'> data (u'query_results.html', <class 'genshi.template.markup.MarkupTemplate'>, ... directive <ForDirective> directives [<ForDirective>] event ('END_NS', , (u'layout.html', 57, 0)) fallback None href u'query_results.html' kind 'INCLUDE' namespaces {: u'http://www.w3.org/1999/xhtml', u'py': ... pos ('query.html', 221, 46) self <MarkupTemplate "query.html"> stream [('DOCTYPE', (u'html', u'-W3CDTD XHTML 1.0 StrictEN', ... substream <generator object at 0xb45818c> tmpl <MarkupTemplate "layout.html"> value {u'each': u'(type_name, type_modes), sep in separated(modes.iteritems())'}
  • File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 231, in load Local variables: Name Value cachekey u'query_results.html' cls <class 'genshi.template.markup.MarkupTemplate'> encoding None filename u'query_results.html' isabs False loadfunc <function _load_from_directory at 0xac53d14> relative_to 'query.html' search_path ['/var/trac/dev.haiku-os.org/templates', ... self <genshi.template.loader.TemplateLoader object at 0x989b46c>

File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request

dispatcher.dispatch(req)

File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 219, in dispatch

data, content_type)

File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/chrome.py", line 683, in render_template

template = self.load_template(filename, method=method)

File "/opt/csw/lib/python/site-packages/Trac-0.11.1-py2.5.egg/trac/web/chrome.py", line 667, in load_template

return self.templates.load(filename, cls=cls)

File "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 221, in loadFile "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 259, in _instantiateFile "build/bdist.solaris-2.10-i86pc/egg/genshi/template/base.py", line 377, in initFile "build/bdist.solaris-2.10-i86pc/egg/genshi/template/base.py", line 444, in _prepareFile "build/bdist.solaris-2.10-i86pc/egg/genshi/template/loader.py", line 231, in load

System Information:

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 Trac: 0.11.1 Python: 2.5.1 (r251:54863, Nov 3 2007, 02:54:36) [C] setuptools: 0.6c8 psycopg2: 2.0.6 Genshi: 0.5 Pygments: 0.10 Subversion: 1.4.5 (hrev25188) jQuery: 1.2.6

TracGuide — The Trac User and Administration Guide

Change History (2)

comment:1 by nielx, 11 years ago

Description: modified (diff)
Owner: changed from haiku-web to nielx

What was the issue of this ticket? Was it within the context of our well-known server hangs?

comment:2 by marcusoverhagen, 11 years ago

Resolution: fixed
Status: newclosed

Probably. Seems to be working fine right now.

Note: See TracTickets for help on using tickets.