Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#3096 closed bug (fixed)

trac "ticket details" is slow

Reported by: marcusoverhagen Owned by: nielx
Priority: normal Milestone: R1
Component: Website/Trac Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Loading http://dev.haiku-os.org/timeline needs around 13 to 20 seconds.

(viewing 5 days back, everything except repository checkins)

Change History (8)

comment:1 in reply to:  description Changed 11 years ago by VinDuv

Replying to marcusoverhagen:

Loading http://dev.haiku-os.org/timeline needs around 13 to 20 seconds.

(viewing 5 days back, everything except repository checkins)

Have you activated "Ticket details" in the "View changes" box ? It seems to slow down Trac considerably.

comment:2 Changed 11 years ago by marcusoverhagen

Summary: trac is slowtrac "ticket details" is slow

Yes, "ticket details" seems to be the culprit. Changing the ticket summary.

comment:3 Changed 11 years ago by nielx

Owner: changed from haiku-web to nielx

Ticket details are a known performance issue. There is even a Trac switch to disable users viewing ticket details in their timelines. I believe this performance hit is caused by the poor data model that Trac uses.

Now the question is, is this worth a ticket in our installation of Trac?

comment:4 Changed 11 years ago by marcusoverhagen

Yes I believe it is. Perhaps adding a "(slow)" after the ticket details switch or short explanation below would be nice.

comment:5 Changed 11 years ago by nielx

I don't know about you, but for me the speed has seemingly increased since the switch to mod_python. What are your experiences?

comment:6 Changed 11 years ago by luroh

I am of the same opinion, Trac now seems much quicker than before the switch.

comment:7 Changed 10 years ago by nielx

Resolution: fixed
Status: newclosed

Speed greatly improved since mod_python switch.

comment:8 Changed 10 years ago by marcusoverhagen

This is really very fast now. Good work nielx!

Note: See TracTickets for help on using tickets.