Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#316 closed enhancement (invalid)

Please enhance the B_MOUSE_UP message with button states.

Reported by: genki@… Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hello,

This is not a bug, but a feature request.

There is a buttons-field in the B_MOUSE_UP message, however it seems it's always

  1. Please enhance the B_MOUSE_UP message with button states.

See this forum post for details: http://haiku-os.org/forums/viewtopic.php?t=725

Change History (2)

comment:1 by axeld, 14 years ago

Resolution: invalid

You also get a B_MOUSE_UP message when other mouse buttons might still be pressed - their status can be found in the "buttons" field of the message. If you need to know which button(s) was pressed before, just remember the value that was part of the B_MOUSE_DOWN message earlier.

comment:2 by axeld, 14 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.