Opened 11 years ago

Closed 11 years ago

#3170 closed bug (invalid)

Firefox wont load home page haikuware.com after navigating from home page

Reported by: HAL Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

There is a problem with Firefox not being able to load certain web pages but this bug is specific to haikuware.com home page. To reproduce:

  1. go to: www.haikuware.com in Firefox.
  2. Click on any link that will stay in haikuware but leave the home page.
  3. Click on the home page link.

Result is; a window pops up asking what to do with "index.php". If you browse from that window to open with Firefox, it will open the download window for downloading "index.php". It is repeatable every time. karl at www.haikuware.com says there is nothing wrong with the web site; he has cross checked with firefox in Senryu, Linux, Mac OS and Windows. I have also checked with BeOSR5.05 BONE and Linux. There is no problem clicking on the home page link

Attachments (1)

Haiku File Types HTML.png (50.4 KB ) - added by HAL 11 years ago.
Haiku File Types

Download all attachments as: .zip

Change History (11)

by HAL, 11 years ago

Attachment: Haiku File Types HTML.png added

Haiku File Types

in reply to:  description ; comment:1 by TheNerd, 11 years ago

Replying to HAL:

There is a problem with Firefox not being able to load certain web pages but this bug is specific to haikuware.com home page. To reproduce:

  1. go to: www.haikuware.com in Firefox.
  2. Click on any link that will stay in haikuware but leave the home page.
  3. Click on the home page link.

Result is; a window pops up asking what to do with "index.php". If you browse from that window to open with Firefox, it will open the download window for downloading "index.php". It is repeatable every time. karl at www.haikuware.com says there is nothing wrong with the web site; he has cross checked with firefox in Senryu, Linux, Mac OS and Windows. I have also checked with BeOSR5.05 BONE and Linux. There is no problem clicking on the home page link

I can second Karl's opinion. It's definitely not a Haikuware problem so it must be something with the Haiku configuration of your installation or a problem with Firefox.

comment:2 by luroh, 11 years ago

I cannot repeat this in Vmware, Haiku rev 28727. What type of Haiku image are you using and where did you get it? What revision? Firefox version and origin? Vmware/qemu/real hardware?

comment:3 by HAL, 11 years ago

I'm usung: pre-alpha-hrev28724 on real hardware, previously the same with pre-alpha-hrev28555. Also the same Firefox 2.0.0.12 that comes with images and now with Firefox 2.0.0.18. I got the Haiku images from: http://haiku-files.org/raw/index.php?dir=&sort=name&order=desc and I got Firefox 2.0.0.18 from: www.bebits.com I am thinking not a lot of people can reproduce this. On Bezilla Live Journal I replied about the release of Ff 2.0.0.18 and I think only one person had seen something similar. On Haikuware I started a thread: http://www.haikuware.com/forum/website/443-recannot-click-on-home-page-icon#443 only one person there had the same bug.

in reply to:  1 comment:4 by tqh, 11 years ago

Replying to TheNerd:

I can second Karl's opinion. It's definitely not a Haikuware problem so it must be something with the Haiku configuration of your installation or a problem with Firefox.

I assume you are running Apache, how have you set up mimetypes for php? Usually when this happens, this seems stranger though, it's because the website hasn't configured Apache to send the text/html mimetype for different cgi-bin applications. A browser is supposed to handle the content according to that mimetype, if it's unknown it doesn't know and guesses. Some browsers manages that, some don't. I just want to make sure that you DO have configured that so I can exclude that option. It something you have to do manually, so if you havn't touched it, you need to do that.

in reply to:  2 comment:5 by HAL, 11 years ago

Replying to luroh:

I cannot repeat this in Vmware, Haiku rev 28727. What type of Haiku image are you using and where did you get it? What revision? Firefox version and origin? Vmware/qemu/real hardware?

I also tried to reproduce this in vmware 2.5.1, Haiku pre alpha hrev28724 on Mandriva linux as host. It was reproduceable.

comment:6 by mmadia, 11 years ago

HAL, please move this to http://ports.haiku-files.org with a component of www-client / mozilla-firefox

comment:7 by HAL, 11 years ago

I am not able to reproduce this anymore using; firefox 2.0.0.21pre, that comes with haiku hrev20401 image.

in reply to:  6 ; comment:8 by HAL, 11 years ago

Replying to mmadia:

HAL, please move this to http://ports.haiku-files.org with a component of www-client / mozilla-firefox

If it is not reproduceable anymore do you still want me to do this. I have not come across HaikuPorts before. To me it looks more like a programmers site and I am not a programmer or only very limited to BASIC. Sorry, I suppose I could try if there is a need now.

in reply to:  8 comment:9 by mmadia, 11 years ago

Replying to HAL:

Replying to mmadia:

HAL, please move this to http://ports.haiku-files.org with a component of www-client / mozilla-firefox

If it is not reproduceable anymore do you still want me to do this. I have not come across HaikuPorts before. To me it looks more like a programmers site and I am not a programmer or only very limited to BASIC. Sorry, I suppose I could try if there is a need now.

If you can't reproduce it, then no, i wouldn't bother creating the ticket. Though in the future, if you encounter an issue specific to BeZillaBrowser, it would be best to report the issue as a New Ticket at http://ports.haiku-files.org.

ticket can be closed.

comment:10 by stippi, 11 years ago

Resolution: invalid
Status: newclosed

Ok then. :-)

Note: See TracTickets for help on using tickets.