Opened 11 years ago

Closed 10 years ago

#3189 closed bug (fixed)

[mail_daemon] crashes in BList::CountItems()

Reported by: karmak Owned by: bga
Priority: normal Milestone: R1
Component: Servers/mail_daemon Version: R1/pre-alpha1
Keywords: Cc: olive@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Recently (r287xx), on real hardware (IBM R52), while fetching my IMAP mail :

#0  0x004bad4e in BList::CountItems () from /boot/beos/system/lib/libbe.so
#1  0x009293a3 in NestedString::CountItems ()
   from /boot/beos/system/add-ons/mail_daemon/inbound_protocols/IMAP
#2  0x00927154 in IMAP4Client::GetMessage ()
   from /boot/beos/system/add-ons/mail_daemon/inbound_protocols/IMAP
#3  0x0058d518 in BRemoteMailStorageProtocol::GetMessage ()
   from /boot/beos/system/lib/libmail.so
#4  0x009281ed in IMAP4Client::GetMessage ()
   from /boot/beos/system/add-ons/mail_daemon/inbound_protocols/IMAP
#5  0x0058230e in BMailProtocol::ProcessMailMessage ()
   from /boot/beos/system/lib/libmail.so
#6  0x0056f044 in BMailChainRunner::get_messages ()
   from /boot/beos/system/lib/libmail.so
#7  0x0056e583 in BMailChainRunner::MessageReceived ()
   from /boot/beos/system/lib/libmail.so
#8  0x003b027b in BLooper::DispatchMessage ()
   from /boot/beos/system/lib/libbe.so
#9  0x003b1be9 in BLooper::task_looper () from /boot/beos/system/lib/libbe.so
#10 0x003b17d7 in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so
#11 0x002389b8 in thread_entry () from /boot/beos/system/lib/libroot.so
#12 0x70080fec in ?? ()

I cannot reproduce it at will, but encountered it more than once.

Change History (5)

comment:1 by karmak, 11 years ago

The same backtrace happens when IMAP server times out during the initial fetch (just after system boot).

comment:2 by karmak, 11 years ago

Cc: olive@… added

comment:3 by bga, 11 years ago

Owner: changed from axeld to bga
Status: newassigned

comment:4 by bga, 10 years ago

This has been fixed sometime ago.

comment:5 by bga, 10 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.