Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3193 closed enhancement (duplicate)

nVidia Realtek ALC1200 Audio driver

Reported by: Luposian Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #1072 Blocking:
Has a Patch: no Platform: x86

Description

Haiku currently (as of R28761) does not seem to support the audio chipset in my Acer Aspire X1200.

Here's the info I pulled from Ubuntu and Haiku:

From Ubuntu 8.10:

00:07.0 Audio device [0403]: nVidia Corporation Realtek ALC1200 8-Channel High Definition Audio Codec [10de:0774] (rev a1)

From Haiku:

device Multimedia controller (Audio device) [4|3|0] vendor 10de: nVidia Corporation device 0774: Unknown

Change History (4)

comment:1 by umccullough, 11 years ago

I suspect that eventually, this chipset will be supported by Haiku's HDA driver:

http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/audio/hda

But since that driver is somewhat incomplete still, and only supports a couple of chipsets, it might be a while.

Have you tried the OpenSound optional package yet? You can add this to your haiku image by editing your UserBuildConfig and adding the line:

AddOptionalHaikuImagePackages OpenSound ;

It's not a perfect solution, but might at least give you sound.

comment:2 by mmlr, 11 years ago

Blocked By: 1072 added
Resolution: duplicate
Status: newclosed

Yes, this device should eventually be supported by the HDA driver. Since there is another enhancement ticket for the HDA driver in general, I guess this can be closed as a duplicate of #1072.

comment:3 by korli, 11 years ago

Feel free to post a syslog

comment:4 by korli, 11 years ago

Could you post a syslog ? Thanks

Note: See TracTickets for help on using tickets.