Opened 11 years ago

Closed 11 years ago

#3201 closed bug (fixed)

MeTOS causes app_server crash .

Reported by: kvdman Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by stippi)

MeTOS:

http://www.haikuware.com/view-details/development/gui-creation/metos

Will trigger an app_server crash. This program use to work fine under Haiku! Not sure where this happened, but it worked at least two months ago.

See attached trace.

Attachments (1)

bt.png (10.6 KB) - added by VinDuv 11 years ago.
Backtrace

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by kvdman

Hmm attaching the screenshot is causing an error in Trac. I've uploaded it here:

http://www.haikuware.com/downloads/registered/metos.tiff

comment:2 Changed 11 years ago by stippi

Description: modified (diff)
Summary: MeTOS causing KDL now.MeTOS causes app_server crash .

It's an app_server crash, not a KDL. And the back trace is unfortunately not useful, since it's for the wrong thread (the main thread). To be on the safe side, if you see such a trace again, try entering the command "cont" into the GDB terminal. That should then drop into the thread that crashed and you can type bt again.

comment:3 Changed 11 years ago by kvdman

It's 100% reproducible here. I've typed in cont and it locks the system.

Changed 11 years ago by VinDuv

Attachment: bt.png added

Backtrace

comment:4 Changed 11 years ago by VinDuv

Reproducible on VMWare, with hrev28775. Hopefully more useful screenshot attached.

comment:5 Changed 11 years ago by stippi

Yes, that's helpful, thanks! Unfortunately, I don't have time to look into it at the moment. And Axel should be more familiar with the code anyways.

comment:6 Changed 11 years ago by anevilyak

That backtrace looks like it could possibly be related to ticket #3066 also. Not exactly the same trace, but similar enough that it could potentially have the same root cause.

comment:7 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev28843.

Note: See TracTickets for help on using tickets.