Opened 10 years ago

Last modified 7 weeks ago

#3224 new bug

Desktop resolution improper at startup

Reported by: Scott Puopolo Owned by: euan
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #7662 Blocking:
Has a Patch: no Platform: x86

Description

During boot screen, icons light up properly [Picture1]. After last icon is lit, entire boot screen shifts to the left (Haiku logo is at left edge of screen) [Picture2]. The mouse appears, the hard drive indicator continues for a few seconds as booting completes. The mouse can be moved but is very slow / choppy [Picture3]. Some artifacts from the underlying desktop can be revealed by moving the mouse. The system seems to be responding to keyboard input but without visual reference it is tough to tell what is happening. Booting this system using safe mode graphics at 1024x768x32 brings up a usable system but with vesa mode graphics. This laptop also boots up under BeOS 5.0.3 with Radeon driver with no issues (even dualhead support). There is no way to specify the correct startup resolution for the Radeon driver in Haiku. I have included an output from listdev and the referenced pictures in the above text.

Attachments (1)

Archive.zip (50.9 KB) - added by Scott Puopolo 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Scott Puopolo

Attachment: Archive.zip added

comment:1 Changed 10 years ago by Scott Puopolo

The listdev output was created under BeOS 5.0.3. Let me know if you would rather have the output from Haiku or if any other diagnostic info is needed.

comment:2 Changed 10 years ago by marcusoverhagen

Component: Audio & VideoDrivers/Graphics/radeon
Owner: changed from marcusoverhagen to euan

comment:3 Changed 8 years ago by scottmc

Blocking: 7662 added

comment:4 Changed 7 weeks ago by waddlesplash

Blocked By: 7662 added
Blocking: 7662 removed
Note: See TracTickets for help on using tickets.