Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3242 closed bug (invalid)

r28828 build fails on haiku

Reported by: bbjimmy Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Link generated/objects/haiku/x86/release/add-ons/kernel/network/notifications/notifications generated/objects/haiku/x86/release/add-ons/kernel/network/notifications/notifications.o: In function `NetNotificationService::NetNotificationService(void)': notifications.cpp:(.text+0xaa): undefined reference to `BPrivate::Referenceable::Referenceable(bool)' collect2: ld returned 1 exit status

rm -f "generated/objects/haiku/x86/release/add-ons/kernel/network/notifications/notifications" gcc -nostdlib -Xlinker --no-undefined -Xlinker -soname="notifications" -o "generated/objects/haiku/x86/release/add-ons/kernel/network/notifications/notifications" "/boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-081024/crtbegin.o" "generated/objects/haiku/x86/release/add-ons/kernel/network/notifications/notifications.o" \ "generated/objects/haiku/x86/release/system/kernel/kernel.so" "/boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-081024/libgcc.a" "/boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-081024/crtend.o" ;

...failed Link generated/objects/haiku/x86/release/add-ons/kernel/network/notifications/notifications ... ...skipped <HaikuImage>haiku.image-copy-files-dummy-beos/system/add-ons/kernel/network for lack of <net>notifications... ...skipped haiku.image for lack of <HaikuImage>haiku.image-copy-files... ...failed updating 1 target(s)... ...skipped 2 target(s)... ...updated 329 target(s)...

Change History (4)

comment:1 Changed 11 years ago by umccullough

Try

jam clean;jam -aq

Worst case, remove the generated/objects and start fresh

comment:2 Changed 11 years ago by anevilyak

Resolution: invalid
Status: newclosed

Indeed, that looks like a stale dependency. Can't reproduce here in any case.

comment:3 Changed 11 years ago by bbjimmy

it is still compiling with:

jam clean;jam -aq

Has not reached the file yet.

comment:4 in reply to:  1 Changed 11 years ago by bbjimmy

Replying to umccullough:

I now have notifications in /BeO51/haiku/generated/objects/haiku/x86/release/add-ons/kernel/network/notifications

seems to be working ... thanks

Note: See TracTickets for help on using tickets.