Opened 10 years ago

Closed 7 years ago

Last modified 3 years ago

#3277 closed bug (invalid)

audio playback not working after a couple hours

Reported by: rossi Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Audio/OpenSound Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Audio playback works fine (e.g. Sounds preferences panel, vlc, ...) shortly after system startup. After using the system for a couple hours (mainly for development work, no heavy media usage) there is no audio anymore, but also no other feedback like system instability, etc. just no audio output.

Haven't testet yet, wether a media server restart will fix this issue, will do so the next time this bug occurs.

Happens on hrev28855 but has been present for quite some while. Will report feedback on hrev28861 tonight.

My system is based on an Intel chipset with HD audio. Listdev output attached, in case hardware details are needed.

Attachments (1)

listdev.log (2.9 KB) - added by rossi 10 years ago.
listdev output

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by rossi

Attachment: listdev.log added

listdev output

comment:1 Changed 10 years ago by rossi

Yes, still happens on hrev28861 ... audio breaksdown somewhen between 5h and 10h uptime ... could test mediaserver restart yet, as my system was totally unusable after 10h uptime ;-( will give it another try tomorrow ...

comment:2 Changed 10 years ago by rossi

MediaServer restart doesn't help, still no audio output.

comment:3 Changed 10 years ago by axeld

Component: - GeneralDrivers/Audio/HDA

Are you using the "hda" or the OSS audio driver?

comment:4 Changed 10 years ago by rossi

I must admit, I've actually no clue ... I'll check the syslog which driver is actually loaded or is there a better way to check? Is there a tool, which list all active drivers (actually would be cool if listdev just for each device gives the current driver if any being used).

comment:5 Changed 10 years ago by axeld

A "listimage 1" should help to determine it. A simpler way would be to just have a look at /dev/audio and see what devices are published there :-)

comment:6 Changed 10 years ago by rossi

stupid me ;-) just figured out that I could just use listimage myself, actually both oss_loader and oss are loaded, therefore I guess the OSS driver is used.

Will remove OSS and see wether the problem persists ...

comment:7 Changed 9 years ago by mpanasyuk

Same problem (no audio after some time) with OSS installed (Creative SB Live! 5.1). No such problem with emuxki driver.

comment:8 Changed 8 years ago by diver

Version: R1/pre-alpha1R1/Development

comment:9 Changed 8 years ago by diver

Version: R1/DevelopmentR1/alpha1

comment:10 Changed 7 years ago by tidux

This is still present in hrev44913 gcc2hybrid on HDA audio on an Eee PC 1005PE. I'm pretty sure it's OpenSound at fault, since sound worked before installing it, even from live media, and there have been tons of problems since then.

comment:11 Changed 7 years ago by diver

Resolution: invalid
Status: newclosed

It looks like the problem is that both original reporter and you had HDA and OSS drivers installed in the same time. As they attach to the same hardware they conflict with each other resulting in all sorts of strange issues.

comment:12 Changed 3 years ago by mmu_man

Component: Drivers/Audio/HDADrivers/Audio/OpenSound

I indeed recall having an issue after usually 6h15 of playback on my ASUS laptop too with OpenSound. Would you mind testing again on a recent nightly with the 4.2_git-2 opensound package? If yes please reopen.

Note: See TracTickets for help on using tickets.