Opened 14 years ago

Closed 11 years ago

#328 closed bug (fixed)

[Tracker] problems with statusbar redraw

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/Tracker Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by stippi)

This is hard to reproduce, but i can do it easy now. Try to do this: start haiku and go to /haiku/beos/system/lib now try to scroll down and at the same time move mouse to the right so you have horizontal scrollbar offset. try several times if it doesn't at first time. when it happens switch to icon view and scroll down you will see lots of statusbar redraw artefacts. Screenshot will follow, tested with rev16836 under vmware.

Attachments (1)

statusbar.PNG (12.3 KB ) - added by diver 14 years ago.
status bar artifact

Download all attachments as: .zip

Change History (15)

by diver, 14 years ago

Attachment: statusbar.PNG added

status bar artifact

comment:1 by axeld, 14 years ago

Owner: changed from bpmagic@… to stippi

comment:2 by diver, 14 years ago

It's still there.

comment:3 by johndrinkwater, 13 years ago

Can you still reproduce? I get laggy redraw inside the statusbar, but the icon view is untouched. hrev17356

comment:4 by diver, 13 years ago

It's still there in hrev17364, at least under vmware.

comment:5 by jackburton, 13 years ago

I found a similar problem: open a folder with many files in it (/boot/beos/bin, for example), keep the ALT button pressed and press the 1, 2, 3 buttons repeatedly, one after another, very fast, to switch from icon to listview mode. After some times, the statusbar will go crazy: it will still be drawn, but clicking on it won't work anymore, like it wasn't there.

comment:6 by stippi, 13 years ago

Description: modified (diff)
Platform: All

It is some time ago that I investigated this bug, but I nailed it down to Tracker sometimes layouting some views on top of another. This explains any drawing issues (not app_servers fault) as well as "non-clickability" (other view receives click). I'm not that familiar with the Tracker code yet, but maybe I fix this someday.

comment:7 by diver, 13 years ago

You could even deadlock Tracker this way!

comment:8 by diver, 12 years ago

Still with us at hrev21691.

comment:9 by stippi, 12 years ago

Component: - General- Applications/Tracker

comment:10 by aldeck, 12 years ago

I'm not sure how to reproduce this, but i moved the vdertical scrollbar like mad and got nothing. hrev23675 / vmware.

comment:11 by aldeck, 11 years ago

Can someone else recheck? It really looks like all the problems cited here are gone.

comment:12 by luroh, 11 years ago

I can't repeat it either. hrev25952, VMware.

comment:13 by diver, 11 years ago

Can't reproduce anymore, please close this one.

comment:14 by aldeck, 11 years ago

Resolution: fixed
Status: newclosed

Thanks for testing! Closing.

Note: See TracTickets for help on using tickets.