Opened 10 years ago

Closed 6 years ago

#3283 closed bug (fixed)

app_server crash while changing screen resolutions with intel_extreme

Reported by: umccullough Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Another app_server crash into GDB on a different machine.

This machine is a Core 2 Duo with 2gb ram and an Intel G33 chipset.

I was playing a video with VLC and overlay in one workspace, I was compiling in a terminal with a couple others running also in a second workspace, and I had Vision running in a 3rd workspace - and while I was in the workspace with Vision, i opened the screen prefs and increased the resolution to 1600x1200 which caused app_server to immediately crash.

I believe I've seen this happen before when changing screen resolutions on this machine.

The machine had been running continuously and solid for the last couple weeks without issue until I attempted this. See attached screenshots. May be similar or even related to #3282, but I'm not sure.

I will keep this machine in this state in case there is any more info I can obtain and provide.

Attachments (2)

app_server_crash_intel1.jpg (390.1 KB) - added by umccullough 10 years ago.
app_server crash in gdb with backtrace
app_server_crashintel2.jpg (388.8 KB) - added by umccullough 10 years ago.
different app_server crash, same G33-based machine

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by umccullough

Attachment: app_server_crash_intel1.jpg added

app_server crash in gdb with backtrace

comment:1 Changed 10 years ago by axeld

This looks like a problem with the overlay code. Not sure on which side yet, but I will see if I can reproduce this problem over here; no need to keep the machine running, I think :-)

comment:2 Changed 10 years ago by koki

Cc: koki added

I seem to have what looks like the same problem running rev 28867 on an Acer Aspire One netbook.

Video hw according to listdev:

device 27ae: Mobile 945GME Express Integrated Graphics Controller

HTH.

comment:3 in reply to:  2 Changed 10 years ago by umccullough

Replying to koki:

I seem to have what looks like the same problem running rev 28867 on an Acer Aspire One netbook.

I believe koki mentioned (in IRC) that in his particular case, it's happening consistently on workspace change (similar to #3282) - and he was also playing video - which may be an underlying factor as I experienced crashes either during, or after playing video.

Changed 10 years ago by umccullough

Attachment: app_server_crashintel2.jpg added

different app_server crash, same G33-based machine

comment:4 Changed 10 years ago by umccullough

I added another screenshot from the same G33-based machine with a different app_server crash.

I was trying to stress it a bit, so I was playing a video in VLC (HaikuRocks.mpg) had Vision open, was running dnetc (pegged the CPUs at 100% at idle priority), had a terminal running several "find" commands in a row to keep some scrolling action going, and then started changing workspaces and changing resolutions. I did this for about 5-10 minutes with no chras.

It seemed pretty stable till I let it sit for a coupld mins - and while doing pretty much nothing (no user-actions) it spontaneously crashed.

I moved the cursor around a bit and it then froze.

comment:5 Changed 10 years ago by Adek336

I encountered a similar crash with the nvidia accelerant shortly after a Tracker crash - see img_1647.jpg in #3289 (http://dev.haiku-os.org/attachment/ticket/3289/img_1647.jpg)

comment:6 Changed 10 years ago by umccullough

I am guessing that the first crash shown here (app_server_crash_intel1.jpg) is a duplicate of #3282, but the second crash (app_server_crashintel2.jpg) appears to be a duplicate of #3289 as pointed out by Adek336

comment:7 Changed 10 years ago by umccullough

I can't remember seeing any workspace-switching crashes in a while.

comment:8 Changed 10 years ago by umccullough

Ignore above comment, wrong ticket. I need to retest this more thoroughly again.

comment:9 Changed 6 years ago by umccullough

Resolution: fixed
Status: newclosed

Closing - I haven't actually seen this issue in years and it was probably fixed somewhere along the way.

Note: See TracTickets for help on using tickets.