Opened 11 years ago

Closed 11 years ago

#3336 closed bug (invalid)

copy too many files, KDL : kernel/fs/vfs.cpp

Reported by: mmadia Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I attempt copying mozilla's cvs 1.8 branch code from one bfs partition to another, Haiku will KDL.

ASSERT FAILED (src/system/kernel/fs/vfs.cpp:1020): vnode->ref_count == 0 && vnode->busy

This applies for using either Tracker or cp -R -L source/* dest

The first KDL occured while the system was up and very active for 8+hrs. This was with Tracker.

Immediately on reboot, I attempted cp -R -L mozilla_source/* dest_another_drive with the same KDL and slightly different backtraces.

This is a fairly recent revision, running natively.

Attachments (4)

DSCN0076.jpg (44.4 KB ) - added by mmadia 11 years ago.
KDL, Tracker displaying progress, no bt
DSCN0077.jpg (142.6 KB ) - added by mmadia 11 years ago.
backtrace of KDL while using Tracker
DSCN0078.jpg (149.8 KB ) - added by mmadia 11 years ago.
backtrace of KDL while using cp ...
mozconfig (2.1 KB ) - added by mmadia 11 years ago.
copy to /boot/home if you attempt to checkout mozilla's sources.

Download all attachments as: .zip

Change History (10)

by mmadia, 11 years ago

Attachment: DSCN0076.jpg added

KDL, Tracker displaying progress, no bt

by mmadia, 11 years ago

Attachment: DSCN0077.jpg added

backtrace of KDL while using Tracker

by mmadia, 11 years ago

Attachment: DSCN0078.jpg added

backtrace of KDL while using cp ...

comment:1 by mmadia, 11 years ago

Just to note:

If I divide the copy procedure into smaller chunks, like 5 to 7 total, it'll be fine.

The KDL occurs when I attempt to the entire directory. Though, I haven't tried to see exactly how many of it's sub-folders can be copied at once before KDL.

comment:2 by scottmc, 11 years ago

sounds like a dupe of alpha blocking #3151

comment:3 by axeld, 11 years ago

Nope, looking at the stack crawls, it's a completely different thing.

by mmadia, 11 years ago

Attachment: mozconfig added

copy to /boot/home if you attempt to checkout mozilla's sources.

comment:4 by mmadia, 11 years ago

If it helps, here are the commands to checkout all of mozilla's sources.

Copy the attached file `mozconfig' to /boot/home

export CVSROOT=:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot ;
cvs co -r MOZILLA_1_8_BRANCH mozilla/client.mk ;
cd mozilla ;
make -f client.mk checkout MOZ_CO_PROJECT=all ; 
cd .. ;

As a note and this probably should be another bug, It's very likely that cvs will mention errors while checking out and fail to successfully download all files. Unfortunately, this is difficult to see as the make command executes several cvs commands. An easy way to check if cvs crapped out is to perform a Tracker query for files named ".new.*"

comment:5 by mmadia, 11 years ago

After re-partitioning, re-initializing, and re-downloading the mozilla source tree. This issue has vanished.

I believe it was due to some filesystem corruption. Specifically caused by a KDL generated by copying files from an older BFS volume with corruption on it to the parition that I later stored the mozilla sources on.

If interested, I should be able to replicate this.

Can be closed as invalid.

comment:6 by korli, 11 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.