Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#3344 closed bug (fixed)

[DiskProbe] Inserting text in find wndow should move cursor

Reported by: diver Owned by: stpere
Priority: normal Milestone: R1
Component: Applications/DiskProbe Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Inserting text in find wndow should move cursor after the last character of the last line.

Attachments (2)

screenshot3 (127.0 KB) - added by diver 10 years ago.
screenshot3.png (127.0 KB) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by stpere

Hi,

It seems fixed, or at least I can't reproduce it. Can someone confirm? :)

comment:2 Changed 10 years ago by diver

Nope, it's still here in hrev32402

comment:3 Changed 10 years ago by humdinger

Maybe diver means when re-opening the find window or when switching between "Text" and "Hex". Here the cursor does get positioned at the beginning instead at the end.

Changed 10 years ago by diver

Attachment: screenshot3 added

Changed 10 years ago by diver

Attachment: screenshot3.png added

comment:4 Changed 10 years ago by diver

Sorry about "screenshot3" attachment, this really needs to be fixed in ScreenShot app.
Anyway try to paste any text copied from DiskProbe itself.

comment:5 Changed 10 years ago by stpere

Owner: changed from axeld to stpere
Status: newassigned

Thanks for the screenshot, will look into this!

comment:6 Changed 10 years ago by stpere

While I'm at it, would it be better if, when you reopen the FindWindow, that the last text searched for (that is shown again) is all selected, so that you can easily replace it if you want.

It's still easier to go at the end (just a right key) if you want to extend it is with than the current "solution"..

comment:7 Changed 10 years ago by stpere

Resolution: fixed
Status: assignedclosed

Hi, this should be fixed in hrev34181. Can you confirm? I will close it for now, but feel free to yell at me! :)

comment:8 Changed 9 years ago by diver

Seems to be fixed, thanks!

Note: See TracTickets for help on using tickets.