Opened 10 years ago

Closed 10 years ago

#3415 closed bug (invalid)

Boot from USB Hard Drive Fails

Reported by: nielx Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/pre-alpha1
Keywords: Cc: mmlr
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've got a 500 GiB USB drive with four partitions: 150 GiB Ext3 150 GiB BFS (for Haiku) 190 GiB empty 1 GiB Swap

I have tried two different Grub configurations. In the first configuration I have grub installed on my own HD. The BIOS boots from the standard HD, which makes that hd0 (in grub terms), and the USB drive hd1. Haiku is on hd1 (hd1,5 to be exact). I enter haiku's boot loader, but it goes straight into the menu, because it cannot find the disk Haiku is on.

The second configuration is where Grub is installed and booted from the USB disk. When I instruct the BIOS to boot from the IDE disk, this disk is hd0, and Haiku is at hd0,5. Now the boot loader finds the disk, but it stalls. I will attach an image of what it looks like. The point where it stalls is the same point, 'kernel entry at 8003ef2d'. That's where it stops doing anything.

(I realize these are actually two separate bugs, but let's focus on the second situation and later look at the multi-hd confuses bootloader thing).

Attachments (1)

05022009006-small.jpg (118.1 KB) - added by nielx 10 years ago.
Screen output

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by nielx

Attachment: 05022009006-small.jpg added

Screen output

comment:1 Changed 10 years ago by nielx

Resolution: invalid
Status: newclosed

Resolving as invalid. Investigation into the nature of the problem have shown the problem is more like #2083. I'll continue there.

Note: See TracTickets for help on using tickets.