Opened 11 years ago

Closed 8 years ago

#3444 closed bug (fixed)

Failing to boot on SATA - ICH7 82801GB/GR/GH

Reported by: moochris Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc: moochris@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hi,

I can't boot from AHCI SATA drive (works in compatibility mode though). I've got a stack trace to attach.

From Linux, lspci gives the controller as 82801GB/GR/GH (ICH7 Family).

Please let me know if there's any other info I can give.

Thanks, Chris

Attachments (1)

12022009076.jpg (168.2 KB ) - added by moochris 11 years ago.
Stack trace

Download all attachments as: .zip

Change History (5)

by moochris, 11 years ago

Attachment: 12022009076.jpg added

Stack trace

comment:1 by moochris, 11 years ago

Cc: moochris@… added

comment:2 by umccullough, 11 years ago

Have you tried swapping the bus_manager from "ide" to "ata" yet?

In order to do this, you'll need to building your own images, and you'll want to edit this file:

http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/bus_managers/Jamfile#L7

comment out the line ending in "ide" and uncomment the line ending in "ata"

Rebuilding your image, and it should pick up the other bus manager and build it instead.

It's a bit slower, and doesn't yet support ATAPI afaik, and may take a while to boot (i have to wait several minutes on the disk icon personally) - but it might give you better results as the "ide" bus_manager has some known issues.

comment:3 by moochris, 11 years ago

Thanks, that works now - as you said it pauses a while, but gets there in the end.

comment:4 by kallisti5, 8 years ago

Resolution: fixed
Status: newclosed

this issue is reported as resolved by the submitter. Closing.

Note: See TracTickets for help on using tickets.