Opened 11 years ago

Closed 11 years ago

#3450 closed bug (fixed)

Tracker windows seem to display duplicate files sometimes.

Reported by: bga Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I had this DVD with around 200 files. I mounted it and used Tracker to copy its contents to an empty folder and was surprised when I got a Tracker popup for one of the files mentioning that it already existed. I looked at the source Tracker window and in fact, there were 2 files with exactly the same name. Just to be sure I checked in terminal and ls would show only one single file.

I tried to gather more information but I did not find anything relevant except for the fact that the Tracker window did not show the file count at the lower left corner of the window as it usually does with all windows.

Maybe related to the optimizations made recently? I am in a very fast 4 cores machine so it could be a locking issue.

Change History (11)

comment:1 by bga, 11 years ago

A bit more information: ls -l showed 203 files in the source folder but only 202 were actually copied (so the duplicate file probably was supposed to refer to a different file). Also, the destination window only shows 201 files (as counted by Tracker) although, as mentioned, there are 202 files on this folder.

comment:2 by bga, 11 years ago

Oh... This was all in list view, BTW.

comment:3 by aldeck, 11 years ago

Yes this is most probably due to one of the last optimisations, i couldn't explain nor reproduce such a case in my tests so we thought it was some kind of paranoid check or old leftover. I guess we'll have to dig this one deeper :)

Thanks for the feedback. Reverting for the time being.

comment:4 by aldeck, 11 years ago

for reference see #3011

comment:5 by aldeck, 11 years ago

Should be back to normal in hrev29229

Will do more tests on the quad here too.

comment:6 by anevilyak, 11 years ago

This makes me wonder if there's a bug in Tracker's node monitoring somewhere that's causing this.

comment:7 by bga, 11 years ago

Well, it does not do node monitoring for the initial population of the window. And I am seeing one less file than exist in the directory after the initial population and no other operation being made in that folder.

comment:8 by bga, 11 years ago

Ops... Ignore the comment where I say that after copying the data Tracker would show less files in the folder than Terminal would. I used "ls -l | wc -l" and "ls -l" writes and extra line. So the number is correct.

The problem with the duplicate entry was real tough, but I can not try to reeproduce it again as I do not have the offending DVD with me anymore.

comment:9 by anevilyak, 11 years ago

Can you reproduce it with data CDs or just hard disk to hard disk transfers? Would be interesting to know as it might help narrow down the culprit.

comment:10 by bga, 11 years ago

I am 99% sure it has nothing to do with the FS at all. I just received emails and got around 150 SPAM messages. I went to my SPAM folder (in Tracker). Selected all files and hit DEL. It started deleting files but then complaining that one file did not exist. As I was in a hurry I didn't investigate further but this matches the case where there would be a duplicate entry pointing to the same file. The first one causes the actual file to be deleted and the second one would error out because the file does not exist anymore.

It is definitely a PoseView thing.

BTW, this is still with the old code. I did not upgrade to the version that reverted the optimization changes yet. I didn´t look at the code but it is obvious to me that in some point the same file is being added twice as different Poses.

comment:11 by anevilyak, 11 years ago

Resolution: fixed
Status: newclosed

This optimization was now done a different way which should no longer have the duplicate problem.

Note: See TracTickets for help on using tickets.