Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#3452 closed enhancement (duplicate)

Vodoo 3 2000 PCI Native Support

Reported by: kvdman Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Graphics Version:
Keywords: Cc:
Blocked By: #6215 Blocking:
Has a Patch: no Platform: All

Description

The following information was gathered from a hardware submission at Haikuware. Perhaps the sources could be acquired and the author could submit the patches?

It works in VESA mode, except for having issues entering 32-bit color depths. I did manage to find a driver that I was able to get working as well, though the driver appears to be an ancient hack job cobbled together from some sample driver code that came with BeOS R5 - using it does get me to 1280x1024@32bpp without issue.

The driver was found here: http://www.falconfly.de/voodoo3.htm (it's at the bottom of the page.)

It comes as source-only with makefiles that were for R5 (so they don't work), and it seems to require a bit of patching to work correctly in the first place.

I also have binaries of the driver that I managed to build if anyone wants them.

See: http://www.haikuware.com/details/voodoo-3-2000-pci

Attachments (1)

driver.c.diff (8.2 KB) - added by chrisv 10 years ago.
Patch of tdfx driver v0.02

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by anevilyak

Component: - GeneralDrivers/Graphics
Type: bugenhancement

comment:2 Changed 10 years ago by umccullough

Perhaps I've missed something, but I didn't see mention in the report that the tdfx driver in Haiku's repo has been tried yet.

I tried it on a Voodoo 3 AGP card some years ago and it almost worked, but I had a different card than that one.

Probably worth a shot, just add it to the image like the other video drivers and see if it compiles.

Changed 10 years ago by chrisv

Attachment: driver.c.diff added

Patch of tdfx driver v0.02

comment:3 Changed 10 years ago by chrisv

Well, the tdfx driver that's there is the same base driver that I'm using, except that I didn't use the PPC ported version, just the Intel-only version of it. About the only specific patch that I made was, in open_hook(...), I forced di->is_open to always be a minimum of 2, otherwise the driver would happily detect the card, and shortly thereafter, the device node would get opened and closed, causing the card to be unmapped and making the display stop working.

I made a few other changes as well, some more debugging notices mostly, but I don't think any of them caused the driver to just start working for me except for the evil hack on is_open.

The patch is against the v0.02 driver (before PPC support was added), though the biggest difference that I could see between the drivers themselves was various bits of endianness changes and being what looks like a bit better behaved with PCI handling.

comment:4 Changed 10 years ago by axeld

Owner: changed from axeld to nobody
Version: R1/pre-alpha1

comment:5 Changed 9 years ago by luroh

Resolution: duplicate
Status: newclosed

Making this a duplicate of #6215, which features a new driver for this card.

comment:6 Changed 9 years ago by luroh

Blocked By: 6215 added
Note: See TracTickets for help on using tickets.