Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3454 closed bug (invalid)

Audio CD doesn't handle invalid filenames during copy

Reported by: tigerdog Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/cdda Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

AudioCD appears to get artist/title info from CD-Text (thank you, nice touch!) but errors out with "Invalid argument" if the CDText track title includes the * (asterisk) character.

Change History (4)

comment:1 by tigerdog, 11 years ago

Additional info: error occurs when copying from Audio CD to FAT partition. Copy works fine to BFS partition.

comment:2 by anevilyak, 11 years ago

That's not really a problem with cdda itself per se, the problem is that FAT doesn't allow a bunch of characters like that in filenames. Not sure what the best way to handle that would be, though hypothetically I suppose they could be stripped or replaced with underscores or whatnot, but right now it's not really discoverable that it doesn't support those without trying the copy and getting back an error to my knowledge.

comment:3 by axeld, 11 years ago

Resolution: invalid
Status: newclosed

FAT is pretty restrictive when it comes to which characters it accepts in file names. This is a file system deficiency that we can't do anything about, though. I've built a temporary hack into Tracker that would automatically translate names when copying to FAT (it's a build time option IIRC).

In the future, we should let the file system itself publish the characters it supports, and how large a name can be, or, alternatively, it should have a function to correct names. Then, Tracker could just use this function, and could ask the user, if the file names that need a rename should be renamed automatically.

comment:4 by tigerdog, 11 years ago

I understand - this really is a FAT issue. Unfortunately, FAT will be with us for quite some time since it really is the only common read/write file system supported across Windows, Haiku, and Linux/Unix. I like the "in the future" idea, Axel. In the meantime, I think it might be good to either enable the temporary tracker hack or at least produce a more meaningful error message. Because I know you're not busy with anything else... ;)

Note: See TracTickets for help on using tickets.