Opened 11 years ago

Closed 7 years ago

#3462 closed bug (fixed)

network problem

Reported by: Giuseppe Owned by: axeld
Priority: low Milestone: R1/alpha4
Component: Drivers/Network/rtl8139 Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I recently updated the partition with Haiku rev. 29065 (works fine!) with the revision 29227.

I have a realtek8139 and with the revision 29227, Firefox 2.0.0.17 stop after loading the first page and i cannot continue browsing the same with netsurf ... I tried to replace all the files related to the rev 29227 netstack with those of 29065 and everything works fine.

Maybe there have been changes that cause the problem ever occurred first with all the previous revisions tested. Sorry for the vagueness but I was not able to understand more.

Change History (7)

comment:1 by umccullough, 11 years ago

Component: Network & InternetDrivers/Network

I suspect it's the driver - that driver has always been problematic (before and after switching to the FBSD version)

I know that the FF 2.0.0.17 optional package has been working fine with Haiku's netstack for many months now.

I'm switching the likely component to network driver pending further reports of this problem from others.

comment:2 by umccullough, 11 years ago

Another note, probably since this is a FBSD driver, you're experiencing interrupt issues - maybe try with hrev29242 to see if that helps.

comment:3 by Giuseppe, 11 years ago

Now I have installed Haiku revision 29293 and the problem is here... no i don't think the problem is the driver because if i replace the network directory in /boot/beos/system/add-ons/kernel with the same directory fron Haiku revision 29065 all works fine!

comment:4 by Giuseppe, 11 years ago

The problem is in the /boot/beos/system/add-ons/kernel/network/protocols because if i raplace this directory in Haiku 29302 with the same directory in Haiku 29065 it-s ok. So maybe some change in tcp or in other protocols.

comment:5 by scottmc, 9 years ago

can you try this again with a recent build?

comment:6 by diver, 8 years ago

Component: Drivers/NetworkDrivers/Network/rtl8139

comment:7 by kallisti5, 7 years ago

Milestone: R1R1/alpha4
Priority: normallow
Resolution: fixed
Status: newclosed

my rtl8139 was working 100% with the latest R1A4 images (verified the rtl8139 driver was in use via listimage). This was most likely resolved with a recent FreeBSD network card driver update.

Note: See TracTickets for help on using tickets.