Opened 11 years ago

Closed 9 years ago

#3464 closed bug (duplicate)

Intel GMA950 - Monitor switches off, freeze on boot

Reported by: moochris Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/pre-alpha1
Keywords: Cc: moochris@…
Blocked By: #3149 Blocking:
Has a Patch: no Platform: x86

Description

Hi,

I'm not sure how to provide any further details on this bug as I can't do a stack trace or anything.

The motherboard is a ASRock Conroe1333-DVI/H that has a GMA950 chipset with a riser card in the PCI-E slot that has a DVI output.

lspci from Linux gives the controller as: 00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

When I boot Haiku, after the very last boot icon the monitor switches off - no signal. Caps/numlock don't seem to work on the keyboard when the monitor is off, so I assume it's frozen as well.

Booting in safe graphics mode works fine.

I've tried removing the DVI riser card and just using VGA, but I get a blank screen instead of the boot icons.

Is there a log file or something that I can check after rebooting in safe graphics mode?

Change History (7)

comment:1 by moochris, 11 years ago

Cc: moochris@… added

comment:2 by Adek336, 11 years ago

Perhaps you're getting a kdl. Does typing <enter>reb<enter> reboot the machine?

in reply to:  2 ; comment:3 by moochris, 11 years ago

Replying to Adek336:

Perhaps you're getting a kdl. Does typing <enter>reb<enter> reboot the machine?

No, didn't work - I guess it's locked-up rather than dropping to KDL.

in reply to:  3 comment:4 by moochris, 11 years ago

It does work if I hit F12, then type <enter>reb<enter>

comment:5 by tonestone57, 11 years ago

Blocked By: 3149 added

Fairly sure this bug is a duplicate of (#3149)

comment:6 by axeld, 9 years ago

Blocked By: 3149 removed

comment:7 by axeld, 9 years ago

Blocked By: 3149 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.