Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3482 closed bug (fixed)

nVidia evga PCI-E 7200GS (256MB) distorted video/hang on boot

Reported by: masopmac1 Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

How to reproduce:

  1. Download the 9:29PM 2/20/09 pre-alpha haiku build
  1. DD the image to a spare SATA disk
  1. Use the boot menu (f8) to boot to HAIKU on the SATA disk

Experienced behavior: Haiku loads through all of the icons and presents a distorted ( shifted) HAIKU loading image and fails to show the desktop or mouse cursor.

Expected behavior: Expected Haiku to boot and use the nVidia accelerant to drive the nVidia evga 7200GS .

Workaround: Booting with fail-safe video ( using VESA ) at 1280x1024 32bit allows the system to boot. * Attempted to use various settings with the nvidia.settings file to no avail.

  • Gathered nVidia log and rom dump by using configuration parameters in the "nvidia.settings" file .

Hardware:

nVidia evga 7200GS with 256MB of vram

3.0ghz Pentium 4 HT on an intel d101ggc motherboard with 2gb of ram

250gb sata disk

Attachments (4)

nvidia.10de_01d3_010000.0.log (78.3 KB) - added by masopmac1 10 years ago.
nVidia log taken while reproducing the issue
nvidia.10de_01d3_010000.rom (64.0 KB) - added by masopmac1 10 years ago.
nvidia.settings ROM dump from the evga 7200GS
7200GS-Boot.png (288.4 KB) - added by masopmac1 10 years ago.
Image taken after reproducing the issue
syslog.log (162.7 KB) - added by masopmac1 10 years ago.
syslog from a fail-safe boot

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by masopmac1

nVidia log taken while reproducing the issue

Changed 10 years ago by masopmac1

Attachment: nvidia.10de_01d3_010000.rom added

nvidia.settings ROM dump from the evga 7200GS

Changed 10 years ago by masopmac1

Attachment: 7200GS-Boot.png added

Image taken after reproducing the issue

Changed 10 years ago by masopmac1

Attachment: syslog.log added

syslog from a fail-safe boot

comment:1 Changed 10 years ago by masopmac1

The display is a dell 2005FPW which the nVidia card is connected to via DVI. The display does 1680x1050 resolution.

comment:2 Changed 10 years ago by rudolfc

Hi there,

Can you tell me what the native resolution of your panel is? If it's above 1680x1050 try an analog connection (VGA style) to see if the behaviour (screen) changes.

I'll try to disable hardware acceleration for your card in the driver to see if that would help soon. I'll let you know here when that's done.

Bye!

Rudolf.

comment:3 Changed 10 years ago by masopmac1

Rudolf,

Thanks for your quick reply. The native resolution of the panel is 1680x1050 @ 60hz . Connected via analog (VGA), I get the same behavior. I will be happy to test any driver modifications.

Regrards,

-Sam

comment:4 Changed 10 years ago by masopmac1

Rudolf,

I disabled the acceleration engine through the "block_acc" option you recently implemented. I can now get a full 1680x1050 @60HZ desktop however, I'm running into the same issue you noted. The drawing in 32-bit is very delayed. Drop to 16 and everything is fast. Thanks for all of your work.

-Sam

comment:5 Changed 10 years ago by rudolfc

Hi again,

You just beat me to it, I was about to disable the engine of your card explicitly. But that's not needed anymore for this test then :-)

Thanks for testing. I'll try to dive into the acceleration engine stuff soon!

Rudolf.

comment:6 Changed 10 years ago by rudolfc

Resolution: fixed
Status: newclosed

Hi,

The acceleration engine wasn't properly powered up up for G72 cards (Geforce 7300, 7400 and 7500) at least.

Fixed since R30783, so closing ticket.

Testable only with pre-R30278 builds, since app_server unfortunately nolonger uses acceleration since then..

Bye!

Rudolf.

comment:7 Changed 10 years ago by masopmac1

Thank you for all of your work on this!

-Sam

Note: See TracTickets for help on using tickets.