Opened 10 years ago

Closed 7 years ago

#3504 closed bug (no change required)

usb_webcam.media_addon and firewire_dv.media_addon makes system freeze on Acer Travelmate 6460

Reported by: vegardw Owned by: modeenf
Priority: normal Milestone: R1
Component: Drivers/FireWire Version: R1/pre-alpha1
Keywords: Cc: vegardw
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Summary

I have a Acer Travelmate 6463WLMi that I tried to install Haiku on.

If either usb_webcam.media_addon or firewire_dv.media_addon (or both of the) is included in the image, Haiku freezes/becomes unresponsive. Some times I also get thrown into KDL after a few minutes.

Steps to reproduce

  • Compile Haiku GCC2 version and install in real partition on a Travelmate 6460 series notebook.
  • Reboot notebook and boot Haiku

Expected results

Haiku boots normal on the notebook

Actual results

Haiku boots, but when starting the media_server the system freezes. Sometimes, after a while you get thrown into KDL

Reproducibility

  • Freezing: Always, happens on every boot.
  • KDL: Not always

Work around

To get Haiku to boot on the notebook I had to either remove both usb_webcam.media_addon and firewire_dv.media_addon from "build/jam/HaikuImage" or change the bootscript to not start the media_server.

Testet on

  • Haiku hrev29362
  • GCC2 version, compiled on Ubuntu Linux 8.10
  • Installed on real partition, running on real HW

Hardware

Acer Travelmate 6463WLMi notebook, P/N LX.TED06.057 with the following specs:

  • Intel Core 2 Duo T5500 CPU
  • Intel 945 PM chipset (i945PM)
  • 2x1GB PC2-4300 SODIMM
  • Ati Mobility Radeon X1300 128MB/256MB Hypermemory
  • Notebook has built-in USB webcam
  • Notebook has firewire controller/firewire port

Additional

If any of the two addons are enabled, the following is printed constantly to the serial log:

ide: ide_timeout() bus 0x80fb5a5c
ide: ide_timeout_dpc() bus 0x80fb5a5c, device 0x81796e80
ide: reset_device() device 0x81796e80
ide: reset_device() device 0x81796e80 success
More than 99% interrupts of vector 11 are unhandled

and

ide: reset_device() device 0x81796aa0
ide: reset_device() device 0x81796aa0 failed, calling reset_bus
ide: reset_bus() device 0x81796aa0, bus 0x80fb5990
More than 99% interrupts of vector 11 are unhandled
ide: reset_bus() device 0x81796aa0, bus 0x80fb5990 success
More than 99% interrupts of vector 11 are unhandled

along with a bunch of "Last message repeated XX times." messages.

With both addons removed these messages is not printed to the serial log.

Attached

Serial logs from booting with both addons, each addon seperate and without any addons

Attachments (7)

2009-03-01_r29362_firewire_dv_usb_webcam.log (143.8 KB) - added by vegardw 10 years ago.
with both addons
2009-03-01_r29362_usb_webcam.log (164.5 KB) - added by vegardw 10 years ago.
with only webcam addon
2009-03-01_r29362_firewire_dv.log (167.7 KB) - added by vegardw 10 years ago.
with only firewire_dv addon
2009-03-01_r29362_both_removed.log (75.9 KB) - added by vegardw 10 years ago.
with both addons removed
device manager.jpg (200.2 KB) - added by vegardw 10 years ago.
dmesg_output.txt (48.4 KB) - added by vegardw 10 years ago.
dmesg output after booting Ubuntu
lspci_output.txt (2.2 KB) - added by vegardw 10 years ago.
lspci output from ubuntu

Download all attachments as: .zip

Change History (22)

Changed 10 years ago by vegardw

with both addons

Changed 10 years ago by vegardw

with only webcam addon

Changed 10 years ago by vegardw

with only firewire_dv addon

Changed 10 years ago by vegardw

with both addons removed

comment:1 Changed 10 years ago by vegardw

Summary: usb_webcam.media_addon and firewire_dv.media_addon makes system freezeon Acer Travelmate 6460usb_webcam.media_addon and firewire_dv.media_addon makes system freeze on Acer Travelmate 6460

comment:2 Changed 10 years ago by mmlr

Can you please check what happens if you remove just the firewire bus_manager (either by removing it from the image or deleting it from /boot/beos/system/add-ons/kernel/bus_managers/firewire).

comment:3 Changed 10 years ago by vegardw

With just the firewire bus_manager removed (both addons included) the system boots without problems, no freezes or ide_reset/ide_timeout messages in the serial console

comment:4 Changed 10 years ago by mmlr

Component: Add-OnsDrivers/FireWire
Owner: changed from axeld to absabs

Then it seems to be an interrupt handling problem with firewire.

comment:5 Changed 10 years ago by korli

This seems weird as both firewire controllers is on irq 10, though the unhandled interrupt is on irq 11. Also I don't know if it's well supported with two controllers.

comment:6 in reply to:  5 Changed 10 years ago by absabs

IIRC, the stack support at most 4 controllers by default.

Very strange. As the log said, there is a firewire ohci controller TI TSB43AB22/A. Another is "vendor=1217, device=f7", it must be O2 Micro Inc's OHCI 1394 Controller. But as I google Acer Travelmate 6460 has only one firewire port. It is crazy to integrate two firewire ohci chip in notebook.

vegardw, would you please to check how many firewire chips are there in your notebook under windows or linux?

comment:7 Changed 10 years ago by korli

lspci for this Travelmate 6460: http://www.linuxquestions.org/questions/linux-newbie-8/acer-travelmate-6460-wireless-problem-664786/

At least there is something wrong with either HDA or USB as they are the sole users of IRQ 11. To me, the "only firewire dv addon" test is weird in this respect.

Changed 10 years ago by vegardw

Attachment: device manager.jpg added

comment:8 Changed 10 years ago by vegardw

attached screenshot of windows xp device manager (sorry for the norwegian windows)

There are two firewire host controllers shown? There are two entries in the device manager under "IEEE 1394 Host Controllers" at least. One is called "OHCI compatible IEEE 1394 host controller", the other is called "Texas Instruments OHCI compatible IEEE 1394 host controller"

Since one of you mentioned something with O2Micro, the SD/MMC etc card reader is shown as "02Micro SmartCardBus Reader"

Changed 10 years ago by vegardw

Attachment: dmesg_output.txt added

dmesg output after booting Ubuntu

Changed 10 years ago by vegardw

Attachment: lspci_output.txt added

lspci output from ubuntu

comment:9 Changed 10 years ago by vegardw

also attached output from dmesg and lspci in Ubuntu

comment:10 in reply to:  9 Changed 10 years ago by absabs

There are 2 firewire controllers. As the log said both use irq 10, but which device use irq 11? why reseting firewire controllers will trigger irq 11. Under linux I know cat /proc/interrupts can tell the detailed information about irq, while under haiku how can I know this?

comment:11 Changed 10 years ago by vegardw

output of the "ints" command in the kdl with firewire bus_manager, usb_webcam.media_addon and firewire_dv.media_addon included in the image:

kdebug> ints
int   1, enabled 1, handled        1, unhandled        0, ACTIVE
        ps2:ps2_interrupt (0x80f365d0), data 0x00000000
int   7, enabled 1, handled        0, unhandled        0
        uhci:InterruptHandler__4UHCIPv (0x80749634), data 0x80f937fc
int  10, enabled 5, handled        2, unhandled        0
        firewire:fwohci_intr (0x8357bde4), data 0x81de1000
        firewire:fwohci_intr (0x8357bde4), data 0x81d29000
        uhci:InterruptHandler__4UHCIPv (0x80749634), data 0x80f93920
        uhci:InterruptHandler__4UHCIPv (0x80749634), data 0x80f936d8
        broadcom570x:intr_wrapper (0x807e778c), data 0x81028488
int  11, enabled 3, handled      411, unhandled  1602771
        oss:ossintr (0x848373e0), data 0x80fd67f8
        ehci:InterruptHandler__4EHCIPv (0x805f3ae4), data 0x80fa3550
        uhci:InterruptHandler__4UHCIPv (0x80749634), data 0x80f935b4
int  12, enabled 1, handled       20, unhandled        0
        ps2:ps2_interrupt (0x80f365d0), data 0x00000000
int  14, enabled 1, handled     4291, unhandled        0
        ide_adapter:ide_adapter_inthand (0x80614a74), data 0x80fbb038
int  15, enabled 1, handled       53, unhandled        1
        ide_adapter:ide_adapter_inthand (0x80614a74), data 0x80fbb070
int 219, enabled 1, handled    21462, unhandled        0
        kernel_x86:apic_timer_interrupt (0x800d2634), data 0x00000000
int 221, enabled 1, handled    59116, unhandled        0
        kernel_x86:i386_ici_interrupt (0x800cb978), data 0x00000000
int 222, enabled 1, handled        0, unhandled        0
        kernel_x86:i386_smp_error_interrupt (0x800cb9b0), data 0x00000000
int 223, enabled 1, handled        0, unhandled        0
        kernel_x86:i386_spurious_interrupt (0x800cb9a4), data 0x00000000

comment:12 Changed 7 years ago by modeenf

Some changes have bean made to the fw_raw driver. Can you check again..

comment:13 Changed 7 years ago by modeenf

Owner: changed from absabs to modeenf
Status: newassigned

comment:14 Changed 7 years ago by vegardw

Unfortunately I don't have the computer any longer, so I'm unable to re-check.

comment:15 in reply to:  14 Changed 7 years ago by modeenf

Resolution: no change required
Status: assignedclosed

Replying to vegardw:

Unfortunately I don't have the computer any longer, so I'm unable to re-check.

Ok I will close it for now. Re open this if the bug still exists.

Note: See TracTickets for help on using tickets.