Opened 11 years ago

Last modified 10 years ago

#3507 reopened bug

Save menuitem in DiskProbe's attribute editor

Reported by: humdinger Owned by: stpere
Priority: normal Milestone: R1
Component: Applications/DiskProbe Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev29283.

When you edit an attribute from DiskProbe's Attributes menu, the "Save" menu item isn't active after you changed the attribute's contents. Only after changing tabs (to the Raw Editor), the "Save" lights up. Changes are recognized though, as an alert pops up when you try to close the window.

Saving attributes directly via ALT+S is OK, but I think for DiskProbe's main view, ALT+S could be a bit dangerous. How about ALT+S doing a "Save As..."? Accidental saving is prevented because the file dialog pops up and for everyone else it's not that much slower to hit ALT+S followed by an ENTER.

When working on a device, ALT+S should probably pop up an "Are you sure?" alert instead of silently saving changes. Or am I too paranoid? DiskProbe is quite scary for the ordinary user... :)

BTW: Since it's not only disks that are probed, maybe a name change as with BeMail -> Mail is in order. "DataProbe"?

Change History (4)

comment:1 by axeld, 11 years ago

For files, DiskProbe is as destructive as your general text editor. Letting Command-S behave differently would be quite annoying IMO. Furthermore, with actual devices, a "Save As" wouldn't even work. DiskProbe doesn't show up on a double click on a file either - you have to explicitly open a file in DiskProbe.

Plus, there is always the undo feature you can use.

About the name, I don't see reason to change it, and DataProbe doesn't sound as nice either :-) It's a hex editor, 'probe' doesn't fit in that well anyway.

So much for the things that don't concern the actual bug reported :-)

comment:2 by stpere, 10 years ago

Owner: changed from axeld to stpere
Status: newassigned

comment:3 by stpere, 10 years ago

Resolution: fixed
Status: assignedclosed

This should be fixed in hrev32402. It also fixes the impossibility to undo/redo, this was caused by the same problem.

comment:4 by stpere, 10 years ago

Resolution: fixed
Status: closedreopened

I reverted my commit. It seems it wasn't totally fixing it. I will commit something more complete/working soon.

Note: See TracTickets for help on using tickets.