Opened 11 years ago

Closed 6 months ago

#3522 closed bug (duplicate)

Openning last track of multitrack CD causes KDL

Reported by: HAL Owned by: nobody
Priority: normal Milestone: R1
Component: File Systems/ISO 9660 Version: R1/Development
Keywords: Cc:
Blocked By: #11455 Blocking:
Has a Patch: no Platform: All

Description

If I mount the last track of a multitrack data CD then either double click or right click and navigate to a file on it, I get KDL. If I mount the first track and do the same there is no KDL or crash. Step to reproduce:

  1. Mount last track of a multitrack data CD.
  2. Right click on it and navigate to a file then click on it.

or double click on the CD icon. Result is KDL. Reproduceable every time. What I am wondering is why a multitrack CD is mountable only in two separate disks instead of one? I burnt this disc myself and it works fine in Linux. The FS is ISO9660. I was testing with hrev29246 on real hardware.

Attachments (1)

KDL bactrace.jpg (473.4 KB ) - added by HAL 11 years ago.

Download all attachments as: .zip

Change History (9)

by HAL, 11 years ago

Attachment: KDL bactrace.jpg added

comment:1 by HAL, 11 years ago

I also tested this bug with hrev29401 and is still reproduceable.

comment:2 by diver, 6 years ago

Component: SystemFile Systems/ISO 9660

Is it still reproducible?

comment:3 by HAL, 6 years ago

It is still reproduceable but steps are different now.

  1. If all tracks are mounted at same time, double clicking track 2 and 3 causes kdl.
  2. If only the first track is mounted, double clicking it works properly.
  3. If only the 4th track is mounted, double clicking it works properly.
  4. If only the 2nd track is mounted double clicking it causes kdl.
  5. If only the 3rd track is mounted double clicking it causes kdl.
  6. If track 1 and 3 are mounted double clicking 1 works properly. Double clicking 3 causes kdl.
  7. If track 1 and 2 are mounted, double clicking 1 works properly. Double clicking 2 causes kdl.

I am not certain if 4 years ago the CD I was testing was more than 2 tracks. The CD I retested now has 4. It does not seem to be the last track double clicking that causes kdl now. In all case where kdl, entering continue + enter, can keep going without freezing or I just get a second kdl but entering contue + enter again and everythingis fine.

comment:4 by HAL, 6 years ago

I forgot step 8. If track 1 and 4 is mounted, double clicking either works properly.

comment:5 by diver, 6 years ago

Version: R1/pre-alpha1R1/Development

comment:6 by pulkomandy, 5 years ago

Probably duplicate of #11455.

comment:7 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:8 by waddlesplash, 6 months ago

Blocked By: 11455 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.