Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3544 closed bug (invalid)

Pressing F12 instantly crashes system with 'Unknown command "uhci_process_transfer"'

Reported by: JeremyVisser Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have a USB keyboard and mouse. If I press the F12 key on my keyboard, the system instantly crashes into a white screen, where the following message is repeatedly printed into some sort of debug console:

Unknown command "uhci_process_transfer". Enter "help" to get a list of all supported commands.

I never typed the command "uhci_process_transfer", so I'm not sure what's causing it think I'm entering commands.

The only mention of "uhci_process_transfer" I can find on the Intertubes is in the changeset [29291].

If Jam worked intuitively, I would have downloaded the source and tried reverting [29291], but typing jam in an attempt to compile just results in "No such file or directory...found 7 target(s)..." which is not very useful.

I don't know if this occurs with a PS/2 keyboard or not.

Environment

Change History (2)

comment:1 Changed 10 years ago by mmlr

Resolution: invalid
Status: newclosed

It's not a bug, it's a feature. F12 is currently configured to enter the kernel debugger. The error messages stem from the fact that you're probably having an OHCI chipset (which is currently unsupported from KDL) instead of UHCI and the UHCI command to transfer data is therefore unavailable. While you can tell if the USB keyboard is going to work while in KDL you can't really detect whether or not a PS/2 keyboard is installed. Therefore you can't just leave KDL again when you detect the missing USB keyboard support. In any case, I've added querying for the availability of the needed commands in hrev29472 so the error messages aren't triggered anymore if the commands are not installed.

comment:2 Changed 10 years ago by JeremyVisser

Ah. Thanks for the info. When I reported the bug, I had no idea that it was actually a debug console I was entering.

I agree -- not a bug, but the weird error messages should be suppressed.

Note: See TracTickets for help on using tickets.