Opened 11 years ago

Closed 11 years ago

#3570 closed enhancement (fixed)

Volume Control in Deskbar: can't avoid undesired volume change

Reported by: Adek336 Owned by: anevilyak
Priority: normal Milestone: R1
Component: Preferences/Media Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Check "Show Volume Control on Deskbar" in the media preflet. Now you may want to setup low volume with the volume control. After some time you may want to adjust the volume further. So you click on the volume control icon and the slider appears. While you're changing volume, you have the mouse button down, as releasing the mouse key would close the volume control. The mouse pointer is still where you clicked on the icon; so it's just a bit above the middle of the slider. On the other hand, the current volume slider position is far to the left.

Experienced behaviour: The instant you move the mouse, volume control sets the slider to the place where the mouse pointer is - so to the middle of the scale. For a split second before you relower the volume, it's loud.

Expected behaviour: after clicking the Volume Control icon on Deskbar, the mouse pointer is moved to the place on the slider which represents current volume.

Change History (3)

comment:1 by stippi, 11 years ago

This will prove to be difficult. With tablets, you cannot position the mouse, since it will just snap back to the absolute pen position. I think the better approach will be to keep the slider open after the first click, close it if the second click goes anywhere outside the slider, otherwise start adopting the slider position after the second click.

comment:2 by anevilyak, 11 years ago

Agreed, I really don't like the idea of moving the mouse pointer without the user's consent, I'll look into doing it the way you describe.

comment:3 by anevilyak, 11 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev29568.

Note: See TracTickets for help on using tickets.