Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3635 closed bug (fixed)

[preferences/screen]MenuField text is clipped by MenuField size

Reported by: chico Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/Screen Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  1. open boot/beos/preferences/screen application.
  2. choose the current workspace
  3. the "current workspace" is cutted by the menufield side

Expected: the menufield text should not be clipped;

Attachments (3)

screen-MenuField-bug.png (127.6 KB) - added by chico 10 years ago.
text in menufield clipped
screen-done.diff (788 bytes) - added by chico 10 years ago.
the menufield size is changed by characters' length
screen.png (13.6 KB) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by chico

Attachment: screen-MenuField-bug.png added

text in menufield clipped

Changed 10 years ago by chico

Attachment: screen-done.diff added

the menufield size is changed by characters' length

comment:1 Changed 10 years ago by idefix

I can't reproduce this with Haiku hrev32063.

comment:2 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

I don't think I've ever seen this, but the Screen preferences are now using the layout engine, anyway, so this has indeed be fixed.

comment:3 Changed 10 years ago by diver

Resolution: fixed
Status: closedreopened

I don't think this is already fixed

VirtualBox 3.0.2 hrev21169

Changed 10 years ago by diver

Attachment: screen.png added

comment:4 Changed 10 years ago by diver

Oh, I mean hrev32169.

comment:5 Changed 10 years ago by anevilyak

Fixed in hrev32171.

comment:6 Changed 10 years ago by anevilyak

Resolution: fixed
Status: reopenedclosed

comment:7 Changed 10 years ago by axeld

The screenshots looked different, don't they? :-)

But as I wrote, "Screen" is now using the layout engine, where it didn't do that before - it can't be the same bug, it's a different one with a similar outcome.

Note: See TracTickets for help on using tickets.