Opened 10 years ago

Closed 7 years ago

#3657 closed bug (no change required)

[styledEdit] cursor's behaviors in moving between lines in different font sizes

Reported by: chico Owned by: korli
Priority: normal Milestone: R1
Component: Applications/StyledEdit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  1. open styledEdit.
  1. press key 's' a few seconds. make last a few characters larger.

  1. press two enter key( deal with the character string like the screenshot 'cursor-before').
  1. move your cursor to the third line, second column.
  1. press down-arraw key once.
  1. then you will the cursor goto the forth line, one column.

Expected:

I am confused the column number is counted by the font size or the number of characters. If the font sizes are different between each line, how does the cursor move up and down?

Attachments (3)

cursor-move-before.png (94.7 KB) - added by chico 10 years ago.
normal-cursor-after.png (90.8 KB) - added by chico 10 years ago.
cursor-move-after.png (94.2 KB) - added by chico 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by chico

Attachment: cursor-move-before.png added

Changed 10 years ago by chico

Attachment: normal-cursor-after.png added

Changed 10 years ago by chico

Attachment: cursor-move-after.png added

comment:1 Changed 10 years ago by chico

I am sorry. I do some mistakes here. I add the wrong screenshot 'normal-cursor-after.png' here. sorry again.

comment:2 Changed 7 years ago by siarzhuk

Resolution: no change required
Status: newclosed

Unfortunately it is not clear what is wrong with current behaviour - it moves to shortest position on the next line. If you think that cursor should follow to exact character position (pos 6 in your sample) on the next line - I have to disappoint you - StyledEditor is not targeted as code editor so it should behave more practical than precise.

I have checked this behaviour throughoutly and found no using problems here. It works as intended.

Note: See TracTickets for help on using tickets.