Opened 10 years ago

Closed 6 years ago

#3659 closed bug (fixed)

[styledEdit] special characters make a new line

Reported by: chico Owned by: korli
Priority: normal Milestone: R1
Component: Applications/StyledEdit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  1. open styledEdit.
  2. press key 's' a few seconds. make last a few characters larger like screenshot 'small-big.png'.
  3. move the cursor into the small characters
  4. press shift+',' (<) or shift+'.' (>) or shift+'8' (*) or shift+'6' (). (Is it shortcut key?)
  5. then it makes a new line. And a little weird, the cursor won't go to the back of the special characters.
  6. If you type '' into the string, the blue line will show. And then press backspace key. The rectangle will show.

Expected: when I input characters in small font size, the phenomenon will not appear. I consider no matter what the font size is, the behaviors should be the same

Attachments (1)

small-big.png (102.9 KB) - added by chico 10 years ago.
the prepared character string

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by chico

Attachment: small-big.png added

the prepared character string

comment:1 Changed 10 years ago by chico

please remove the cursor-big.png. Thanks

comment:2 Changed 7 years ago by siarzhuk

Anybody can confirm this? I suspect either keymap (which one?) was broken or NumLock was active on compact Laptop-like keyboard. I cannot reproduce this in latest revisions.

comment:3 Changed 6 years ago by siarzhuk

Resolution: fixed
Status: newclosed

Not observed, no feedback. Feel free to reopen in case the problem arise again.

Note: See TracTickets for help on using tickets.