Opened 11 years ago

Closed 11 years ago

#3674 closed bug (fixed)

DeskCalc should center the text in its display field

Reported by: jonas.kirilla Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/DeskCalc Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When resizing DeskCalc, text is centered vertically, but when closing and reopening the application, the same text is not centered anymore, but aligned (almost) with the bottom of the display field.

Attachments (1)

patch (1.3 KB ) - added by stpere 11 years ago.

Download all attachments as: .zip

Change History (3)

by stpere, 11 years ago

Attachment: patch added

comment:1 by stpere, 11 years ago

The bug was caused by the fact that the inset in the textview was calculated before adjusting the font size. By enlarging the window, you didn't notice it because the font was following closely (it was calculated with the font from the previous iteration..) But at startup, it was calculating the inset using the small default font.

This patch just move the font adjustment before the inset adjustment.

Maybe I/we should convert this application to Layouts..

comment:2 by stippi, 11 years ago

Resolution: fixed
Status: newclosed

Thanks a bunch. I was trying hard to understand this bug a few days ago... must have been half a sleep or something. (Wishful thinking.)

Applied in hrev30101.

Note: See TracTickets for help on using tickets.