Opened 11 years ago

Closed 11 years ago

#3678 closed bug (fixed)

[touchpad][patch] Touchpad keep sending extended packets after a shutdown

Reported by: oco Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Mouse/PS2 Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Warning : Touchpad support should be enabled in the source tree to reproduce this problem.

When rebooting from Haiku to BeOS, the mouse cursor is not moved correctly.

The touchpad driver should send again standard ps2 packet when leaving.

This is the purpose of the attached patch.

Note : it will become usefull only after resolving the TODO in src/system/kernel/shutdown.c (close all services before leaving).

Tested using this command line :

kill <id_AppServer> <id_InputServer>; shutdown -r

Attachments (3)

touchpad_reset_r29384.diff (1.5 KB ) - added by oco 11 years ago.
shutdown.c.diff (791 bytes ) - added by oco 11 years ago.
Patch shutdown.c
shutdown.c.2.diff (936 bytes ) - added by oco 11 years ago.
Updated patch after discussion beetween axeld, stippi and mmu_man

Download all attachments as: .zip

Change History (8)

by oco, 11 years ago

Attachment: touchpad_reset_r29384.diff added

comment:1 by stippi, 11 years ago

Thanks! Committed in hrev29920. I keep the bug open, because the actual symtoms are not yet fixed, as long as input drivers are not closed on shutdown.

by oco, 11 years ago

Attachment: shutdown.c.diff added

Patch shutdown.c

comment:2 by oco, 11 years ago

Thanks for committing ! Patch to have input drivers closed on shutdown (oco + korli). Please review and commit.

by oco, 11 years ago

Attachment: shutdown.c.2.diff added

Updated patch after discussion beetween axeld, stippi and mmu_man

comment:3 by oco, 11 years ago

Updated patch after discussion beetween axeld, stippi and mmu_man. Please update the comment if necessary. I am not sure i get all the points.

in reply to:  2 comment:4 by anevilyak, 11 years ago

Replying to oco:

Thanks for committing ! Patch to have input drivers closed on shutdown (oco + korli). Please review and commit.

Wouldn't that hypothetically prevent being able to click the Restart button if you pick shutdown instead of restart from Deskbar by mistake?

comment:5 by stippi, 11 years ago

Resolution: fixed
Status: newclosed

Thanks, seems like you got all points just fine! :-D To Rene: That's just the point. The new patch does not stop services unless you actually reboot. So when you attempted to shutdown, input_server will still be running and you can press the Reboot button.

Applied in hrev29948.

Note: See TracTickets for help on using tickets.