Opened 5 years ago

Closed 5 years ago

#3689 closed bug (duplicate)

No splash screen at boot with nVidia GeForce MX440

Reported by: haiqu Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Using the driver at http://www.bebits.com/app/3636 I get normal operation under BeOS 5.0.3 Pro.

Using Haiku on the same machine, nothing is visible until the main screen comes up after about 10 seconds. After this, it's all good.

Change History (9)

comment:1 Changed 5 years ago by haiqu

Further information on this ... I tried attaching a second monitor to see if the splash screen came up on it, not really expecting a result. What happened was that it did nothing at all. I checked resolutions and found that no widescreen modes are available.

Then realizing the card isn't being detected at all and that I'm probably in some generic Vesa mode, I changed resolution from 1024 x 768 / 32 bit to 800 x 600 / 16 bit for faster response, and Hey Presto! now I get a splash screen on boot.

Looks like the nVidia driver doesn't cover this card.

comment:2 Changed 5 years ago by stippi

Contrary to BeOS, our VESA mode is actually pretty good, and running at 32bpp will be the fastest. At 16bpp, there needs to be half the video memory to be written, but it also does a CPU intensive colorspace conversion. So unless you have an old computer with slow bus speed, running at 32bpp will be much faster.

comment:3 Changed 5 years ago by haiqu

Checked this further by renaming the vesa driver and confirmed that the system is actually loading te nVidia driver. Apprently the nVidia driver is only set up for a single head, and that there's some issue with displaying the splash screen at 1024 x 768.

My newer machine has an S3 Unichrome Pro onboard and that works fine.

comment:4 Changed 5 years ago by anevilyak

  • Owner changed from axeld to rudolfc

comment:5 Changed 5 years ago by rudolfc

Hi,

you might be plagued by what I described in ticket #3850. Try 1024x768 mode in depth 16bit or a lower res mode in 32bit color: this should give you your splashscreen, maybe even with the second screen connected.

The driver is working I expect (what's your cardID?? so I can check).

Stippy is right I think: try using your desktop at 32bit mode, but try the splashscreen at 16bit mode (trick: set the 32bit mode using 'Screen', exit that app, wait a wile, and then manually modify the 'vesa' file in home/settings/kernel/drivers (I think). Change the 32 in 16 there (open with styled edit), then reboot.

Please let me know what you find.. :-)

Bye!

Rudolf.

comment:6 Changed 5 years ago by rudolfc

Ah, that's home/config/settings/kernel/drivers ..

comment:7 Changed 5 years ago by haiqu

Hi Rudolf,

Tried changing the vesa config file to 1024 x 768 x 16 (after first selecting 1024 x 768 x 32 in Screen settings) and rebooted. Yes, we have a splash screen. :D

I wouldn't know if this is the same problem you reported later, but happy to be able to use a higher resolution now. My only real concern was that if I needed to use Safe Mode I couldn't see it.

Thanks. Very useful patch indeed.

comment:8 Changed 5 years ago by haiqu

Oh yeah, it's a 10de:0171 (NV17 [GeForce4 MX 440])

comment:9 Changed 5 years ago by rudolfc

  • Resolution set to duplicate
  • Status changed from new to closed

Your card is indeed supported (checked ID).
Thanks for testing!

Closing this ticket as it's a duplicate of #3850.

If you don't agree, let me know :-)

Bye!

Rudolf.

Note: See TracTickets for help on using tickets.